summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2017-07-23 01:47:17 -0400
committerPablo Lezaeta Reyes2017-07-23 01:47:17 -0400
commit917c4d99c98dd360d339807f39275730adf9575c (patch)
tree04ea8dd26fe6a945a511ef580905a945bbf94a99
parentc11c6f6f0ec2e9b6ce502ad9672642210accc781 (diff)
downloadaur-917c4d99c98dd360d339807f39275730adf9575c.tar.gz
Improve the description and packaging
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD16
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05f7eed512b2..cb3e4df2af54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
-# Generated by mksrcinfo v8
-# Fri Mar 18 01:04:51 UTC 2016
pkgbase = libertas-firmware
- pkgdesc = Firmware for Marvell's libertas wireless chip series
+ pkgdesc = Firmware for the Marvell Libertas wlan chipsets (OLPC, GuruPlug)
pkgver = 9.70.7.p0.0
- pkgrel = 2
+ pkgrel = 4
url = http://dev.laptop.org/pub/firmware/libertas/
arch = any
license = custom
- source = libertas-firmware.tar.gz::http://ftp.de.debian.org/debian/pool/non-free/libe/libertas-firmware/libertas-firmware_9.70.7.p0.0.orig.tar.gz
+ source = libertas-firmware-libertas-firmware.tar.gz::http://ftp.de.debian.org/debian/pool/non-free/libe/libertas-firmware/libertas-firmware_9.70.7.p0.0.orig.tar.gz
source = License
md5sums = 65bc820fa3afbd8dfb420d7bd77eaca0
md5sums = c82933358ba7f6c9fd546d061a79de99
diff --git a/PKGBUILD b/PKGBUILD
index 37fdca341d51..2b426b9116f3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
pkgname=libertas-firmware
pkgver=9.70.7.p0.0
-pkgrel=2
-pkgdesc="Firmware for Marvell's libertas wireless chip series"
+pkgrel=4
+pkgdesc="Firmware for the Marvell Libertas wlan chipsets (OLPC, GuruPlug)"
url="http://dev.laptop.org/pub/firmware/libertas/"
license=("custom")
arch=("any")
# Use Debian Sid source, they found (now) missing firmwares in upstream server
-source=("$pkgname.tar.gz::http://ftp.de.debian.org/debian/pool/non-free/libe/libertas-firmware/libertas-firmware_9.70.7.p0.0.orig.tar.gz"
+source=("${pkgname}-${pkgname}.tar.gz::http://ftp.de.debian.org/debian/pool/non-free/libe/libertas-firmware/libertas-firmware_9.70.7.p0.0.orig.tar.gz"
"License")
package(){
- install -d 644 "$pkgdir/usr/lib/firmware"
- install -d 644 "$pkgdir/usr/share/doc/$pkgname"
- install -Dm 755 "$srcdir/License" "$pkgdir/usr/share/doc/$pkgname"
- cp -r -a $srcdir/$pkgname-$pkgver/*bin $pkgdir/usr/lib/firmware
+
+ install -d 644 "${pkgdir}/usr/lib/firmware"
+ install -D -m644 "${srcdir}/License" "${pkgdir}/usr/share/licenses/${pkgname}/License"
+ cp -rav "${srcdir}/${pkgname}-${pkgver}/"*bin "${pkgdir}/usr/lib/firmware"
+
+ # Present on linux-firmware
rm "$pkgdir/usr/lib/firmware/lbtf_usb.bin"
}