summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2021-08-29 10:07:35 +0200
committerjnanar2021-08-29 10:10:46 +0200
commita59054ee0879712891a49a39260ba4c72741fc8c (patch)
tree8837a037fd6a29ff8356e071d51879fb6bbd2a09
downloadaur-a59054ee0879712891a49a39260ba4c72741fc8c.tar.gz
RENAME: following upstream announcement, the package has been renamed.
See https://www.goffi.org/b/libervia-progress-note-2021-w18-i4HD
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD33
-rw-r--r--libervia-web-hg.install21
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b972ac1f442
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = libervia-web-hg
+ pkgdesc = Salut à Toi, multi-frontends multi-purposes XMPP client (Web interface)
+ pkgver = 0.7.0.r1451.526318c48953
+ pkgrel = 1
+ url = http://salut-a-toi.org/
+ install = libervia-web-hg.install
+ arch = any
+ license = AGPL3
+ makedepends = python-setuptools
+ makedepends = mercurial
+ depends = python
+ depends = python-jinja
+ depends = python-shortuuid-git
+ depends = libervia-media-hg
+ depends = libervia-backend-hg
+ depends = libervia-templates-hg
+ depends = python-zope-interface
+ depends = python-pyopenssl
+ depends = python-autobahn
+ depends = dbus
+ depends = python-brython
+ provides = libervia-web
+ options = !strip
+ source = hg+https://repos.goffi.org/libervia
+ md5sums = SKIP
+
+pkgname = libervia-web-hg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9976483beeaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: jnanar <info@agayon.be>
+
+pkgname='libervia-web-hg'
+_realname=libervia
+pkgver=0.7.0.r1451.526318c48953
+_version=0.7.0
+pkgrel=1
+url="http://salut-a-toi.org/"
+arch=('any')
+pkgdesc="Salut à Toi, multi-frontends multi-purposes XMPP client (Web interface)"
+provides=('libervia-web')
+depends=('python' 'python-jinja' 'python-shortuuid-git' 'libervia-media-hg' 'libervia-backend-hg' 'libervia-templates-hg' 'python-zope-interface' 'python-pyopenssl' 'python-autobahn' 'dbus' 'python-brython')
+makedepends=('python-setuptools' 'mercurial')
+license=('AGPL3')
+install=$pkgname.install
+source=("hg+https://repos.goffi.org/libervia")
+
+md5sums=('SKIP')
+
+options=('!strip')
+
+pkgver() {
+ cd "$srcdir/$_realname"
+ printf "$_version.r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+
+package(){
+ cd "$srcdir/$_realname"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ install -dm755 etc
+ cp ../../sat.conf etc/
+ }
diff --git a/libervia-web-hg.install b/libervia-web-hg.install
new file mode 100644
index 000000000000..640c68f2deaa
--- /dev/null
+++ b/libervia-web-hg.install
@@ -0,0 +1,21 @@
+print_info() {
+ echo "In order to use libervia, you need a XMPP account, sat-xmpp installed and configured. "
+ echo "Please read the instructions of the official documentation: https://wiki.goffi.org/wiki/Libervia/en"
+ echo "To use Libervia, you'll need to create a "libervia" profile with corresponding account on your XMPP server."
+ echo "example with Prosody:"
+ echo "prosodyctl adduser libervia@your_domain.tld # you will be prompted for a password"
+ echo " jp profile create libervia -j libervia@your_domain.tld -p "
+ echo "<libervia_password>"
+ echo "Of course replace "your_domain.tld" with your actual domain."
+}
+
+
+
+post_upgrade(){
+print_info
+}
+
+post_install(){
+
+print_info
+}