summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Riches2015-08-11 17:39:26 +0100
committerJoseph Riches2015-08-11 17:39:26 +0100
commit18d5502329cdf2ab75d81e9ad9e4210ed6be2e50 (patch)
treefb6836a72a23d74ebf70b29d86ab4b72f739c821
parentbf28d2619c2f4ee8f812746dc9e11bd41fdb818e (diff)
downloadaur-18d5502329cdf2ab75d81e9ad9e4210ed6be2e50.tar.gz
libevdevc: install from prebuilt .deb package
* Use .deb package from upstream maintainer's ppa * This is not a -git package
-rw-r--r--.SRCINFO15
-rw-r--r--ChromiumOS_Licence.txt27
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a04707b40d8b..241242df3c43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,14 +6,15 @@ pkgbase = libevdevc
arch = i686
arch = x86_64
license = custom:chromiumos
- makedepends = git
- makedepends = python2
- makedepends = check
- makedepends = valgrind
- makedepends = doxygen
depends = glibc
- source = libevdevc::git+https://github.com/hugegreenbug/libevdevc.git
- md5sums = SKIP
+ options = !emptydirs
+ options = !strip
+ source = ChromiumOS_Licence.txt
+ md5sums = af314be4bf04a749665a07203b120f54
+ source_i686 = libevdevc_2.0-ubuntu4_i386.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/libevdevc_2.0-ubuntu4_i386.deb
+ md5sums_i686 = 287715207a88d3f213a80d15332133a6
+ source_x86_64 = libevdevc_2.0-ubuntu4_amd64.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/libevdevc_2.0-ubuntu4_amd64.deb
+ md5sums_x86_64 = f76beab95337525666e03789bd250c24
pkgname = libevdevc
diff --git a/ChromiumOS_Licence.txt b/ChromiumOS_Licence.txt
new file mode 100644
index 000000000000..69b485551f00
--- /dev/null
+++ b/ChromiumOS_Licence.txt
@@ -0,0 +1,27 @@
+// Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
+//
+// Redistribution and use in source and binary forms, with or without
+// modification, are permitted provided that the following conditions are
+// met:
+//
+// * Redistributions of source code must retain the above copyright
+// notice, this list of conditions and the following disclaimer.
+// * Redistributions in binary form must reproduce the above
+// copyright notice, this list of conditions and the following disclaimer
+// in the documentation and/or other materials provided with the
+// distribution.
+// * Neither the name of Google Inc. nor the names of its
+// contributors may be used to endorse or promote products derived from
+// this software without specific prior written permission.
+//
+// THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+// "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+// LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+// A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+// OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+// SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+// LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+// DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+// THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+// (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+// OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 2e591d2c5e45..88d73798569a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,5 @@
+# Maintained by Joseph Riches
+
pkgname=libevdevc
pkgdesc="Chromium OS libevdev"
pkgver=2.0
@@ -5,24 +7,18 @@ pkgrel=1
arch=(i686 x86_64)
url="https://github.com/hugegreenbug/libevdevc"
license=('custom:chromiumos')
-_gitname='libevdevc'
depends=('glibc')
-makedepends=('git' 'python2' 'check' 'valgrind' 'doxygen')
-
-source=("$_gitname::git+https://github.com/hugegreenbug/libevdevc.git")
+options=('!emptydirs' '!strip')
-md5sums=('SKIP')
+source=('ChromiumOS_Licence.txt')
+source_x86_64=("${pkgname}_${pkgver}-ubuntu4_amd64.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/${pkgname}_${pkgver}-ubuntu4_amd64.deb")
+source_i686=("${pkgname}_${pkgver}-ubuntu4_i386.deb::https://launchpad.net/~hugegreenbug/+archive/ubuntu/cmt2/+files/${pkgname}_${pkgver}-ubuntu4_i386.deb")
-build() {
- cd "$srcdir/$_gitname"
- make
-}
-
-check() {
- cd "$srcdir/$_gitname"
- make check || /bin/true
-}
+md5sums=('af314be4bf04a749665a07203b120f54')
+md5sums_x86_64=('f76beab95337525666e03789bd250c24')
+md5sums_i686=('287715207a88d3f213a80d15332133a6')
package() {
- make -C "$srcdir/$_gitname" DESTDIR="${pkgdir}" install
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+ install -Dm644 ChromiumOS_Licence.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENCE
}