summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaryl Chng2017-01-12 14:46:27 +0800
committerJaryl Chng2017-01-12 14:46:27 +0800
commit597c4f0fdafc1e3d73b8f9cb9e7264cb7a5f1fac (patch)
tree55045071101323a97c04799b1d874e0c9d75e401
downloadaur-597c4f0fdafc1e3d73b8f9cb9e7264cb7a5f1fac.tar.gz
20161109.11a3f476
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc1d0ceb9ccf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libewf-git
+ pkgdesc = Library to access the Expert Witness Compression Format (EWF)
+ pkgver = 20161109.11a3f476
+ pkgrel = 1
+ url = https://github.com/libyal/libewf
+ arch = any
+ license = LGPL
+ makedepends = git
+ provides = libewf-git
+ conflicts = libewf
+ source = git+https://github.com/libyal/libewf.git
+ sha1sums = SKIP
+
+pkgname = libewf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2108d8cfe07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jaryl Chng <mrciku@gmail.com>
+pkgname=libewf-git
+pkgver=20161109.11a3f476
+pkgrel=1
+pkgdesc='Library to access the Expert Witness Compression Format (EWF)'
+arch=('any')
+url='https://github.com/libyal/libewf'
+license=('LGPL')
+provides=('libewf-git')
+conflicts=('libewf')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+options=()
+source=('git+https://github.com/libyal/libewf.git')
+sha1sums=('SKIP')
+
+_gitname="libewf"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "$_gitname"
+
+ ./synclibs.sh
+ sed -i '/ewftools/d' Makefile.am
+ sed -i '/ewftools/d' configure.ac
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file