summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcylgom2018-04-10 09:43:42 +0200
committercylgom2018-04-10 09:43:42 +0200
commiteaa47f870f6884ea71409808eb510c5d1a4771dc (patch)
tree2c526c3b450f518438991664237a26354f9fceaf
downloadaur-eaa47f870f6884ea71409808eb510c5d1a4771dc.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be79f3b9d7d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libexcalibar-git
+ pkgdesc = excalibar core (plugins interface)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/cylgom/excalibar
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = libxcb
+ depends = cairo
+ depends = pango
+ source = git+https://github.com/cylgom/excalibar.git
+ md5sums = SKIP
+
+pkgname = libexcalibar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1668c0c5c577
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: cylgom <cylgom@gmail.com>
+pkgname=libexcalibar-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="excalibar core (plugins interface)"
+arch=('i686' 'x86_64')
+url="https://github.com/cylgom/excalibar"
+license=('custom:WTFPL')
+makedepends=('git')
+depends=('libxcb' 'cairo' 'pango')
+source=('git+https://github.com/cylgom/excalibar.git')
+md5sums=('SKIP')
+
+build() {
+ cd excalibar/lib
+ make
+}
+
+package() {
+ cd excalibar/lib
+ make DESTDIR="$pkgdir" install
+ install -D -m644 ../LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
+}