summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-03-25 00:54:18 +0800
committerChocobo12021-03-25 00:57:46 +0800
commitd2d48bfeb2cccd5e78472d7e22dc380d26c6ca39 (patch)
treebc608925b860902973b8181467f95498541e2607
downloadaur-d2d48bfeb2cccd5e78472d7e22dc380d26c6ca39.tar.gz
newpkg: libexif-git 0.6.22.r24.g977d8ff-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ac38e7c31ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libexif-git
+ pkgdesc = A library for parsing, editing and saving EXIF data
+ pkgver = 0.6.22.r24.g977d8ff
+ pkgrel = 1
+ url = https://libexif.github.io/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = libexif
+ provides = libexif.so
+ conflicts = libexif
+ options = staticlibs
+ source = git+https://github.com/libexif/libexif.git
+ sha256sums = SKIP
+
+pkgname = libexif-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a1af1cc1ee9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libexif-git
+pkgver=0.6.22.r24.g977d8ff
+pkgrel=1
+pkgdesc="A library for parsing, editing and saving EXIF data"
+arch=('i686' 'x86_64')
+url="https://libexif.github.io/"
+license=('LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('libexif' 'libexif.so')
+conflicts=('libexif')
+options=('staticlibs')
+source=("git+https://github.com/libexif/libexif.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libexif"
+
+ git describe --long --tags | sed 's/^libexif-//;s/-release//;s/\([^-]*-g\)/r\1/;s/[-_]/./g'
+}
+
+build() {
+ cd "libexif"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "libexif"
+
+ make check
+}
+
+package() {
+ cd "libexif"
+
+ make DESTDIR="$pkgdir" install
+}