summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2019-07-15 08:15:24 +0200
committerayekat2019-07-15 08:15:24 +0200
commitc6221527ccf84b17db817631f6af7429af78b736 (patch)
tree296a5ac050c2438433d2236c4a70985a824a66de
parent4c7bfe92b88cf9b45f8246c6a04584196924ec8c (diff)
downloadaur-c6221527ccf84b17db817631f6af7429af78b736.tar.gz
Let user enable 0004-fix-void-args patch
This is a patch that noticeably deviates from upstream's default, and while it solves an issue, this should better be taken to upstream by soomeone who properly understands the consequences of this change. The patch is kept around for users who want a quick fix (but disabled by default).
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 522aa0189d56..b88aca023535 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,11 +34,14 @@ pkgver() {
prepare() {
cd libfiber
- # use downstream (distribution) libev
+ # Use downstream (distribution) libev:
patch -p1 -i "$srcdir"/0002-dist-libev.diff
- # don't use work stealing
- patch -p1 -i "$srcdir"/0003-no-work-stealing.diff
+ # Don't use work stealing:
+ # NOTE: This is disabled by default, as it deviates from vanilla upstream;
+ # apply if you run into issues with fibers being scheduled in an awkward way.
+ #patch -p1 -i "$srcdir"/0003-no-work-stealing.diff
+
}
build() {