summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarol Babioch2019-12-07 16:47:57 +0100
committerKarol Babioch2019-12-07 16:49:53 +0100
commit7def8f31f9981f4792d8a1f3377fc2590300f276 (patch)
tree88adefa5f63edec788b7038dcfa71b96db0e717e
parentba6b6205ba9486a42668b4156a59f489dd24b6ae (diff)
downloadaur-7def8f31f9981f4792d8a1f3377fc2590300f276.tar.gz
Use upstream tarball (including signature) as source instead of git tree
This uses the tarballs listed on the official releases website [1] as source for the build process, since this has been requested via comments for this AUR package [2]. [1]: https://developers.yubico.com/libfido2/Releases/ [2]: https://aur.archlinux.org/packages/libfido2/
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1a5baa8cf6d..43d626021957 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,26 @@
pkgname=libfido2
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="Provides library functionality for FIDO 2.0, including communication with a device over USB"
arch=('x86_64')
url="https://developers.yubico.com/libfido2/"
license=('BSD')
depends=('openssl' 'libcbor' 'hidapi')
makedepends=('git' 'cmake')
-source=("git+https://github.com/Yubico/libfido2.git#tag=$pkgver")
-sha256sums=('SKIP')
+source=("https://developers.yubico.com/libfido2/Releases/libfido2-${pkgver}.tar.gz"
+ "https://developers.yubico.com/libfido2/Releases/libfido2-${pkgver}.tar.gz.sig")
+sha256sums=('0b2e3671c4c5d42fd5604a08e45f89f49592b97cf66d7d3bfbc7e6a4d5a0fec7'
+ 'SKIP')
+validpgpkeys=('EE90AE0D19774C8386628FAAB428949EF7914718')
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
mkdir build
}
build() {
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/$pkgname-$pkgver/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -26,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/$pkgname-$pkgver/build"
make DESTDIR="$pkgdir/" install
install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}