summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-11-02 08:47:16 +0100
committerMarco Pompili2015-11-02 08:47:16 +0100
commit134e933b071fc63f3ae833918052d57a96fd9640 (patch)
tree0dc93114e13d0dd52b2535b15c05623689ea07c2
downloadaur-134e933b071fc63f3ae833918052d57a96fd9640.tar.gz
Initial commit, v1.7.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d74fc8ae697
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libfixbuf
+ pkgdesc = libfixbuf is a compliant implementation of the IPFIX Protocol, as defined in the "Specification of the IPFIX Protocol for the Export of IP Flow Information" (RFC 5101).
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = http://tools.netsa.cert.org/fixbuf/index.html
+ arch = i686
+ arch = x86_64
+ groups = netsa
+ license = LGPL
+ depends = glibc>=2.6.4
+ source = http://tools.netsa.cert.org/releases/libfixbuf-1.7.1.tar.gz
+ md5sums = 46d5d0362581a09902b24635b4679b6a
+
+pkgname = libfixbuf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7233d6ef5ecb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+libfixbuf-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0520ce0ac39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname="libfixbuf"
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="A compliant implementation of the IPFIX Protocol, as defined in the \"Specification of the IPFIX Protocol for the Export of IP Flow Information\" (RFC 5101). "
+arch=('i686' 'x86_64')
+url="http://tools.netsa.cert.org/fixbuf/index.html"
+license=("LGPL")
+groups=("netsa")
+depends=("glib2>=2.6.4")
+source=("http://tools.netsa.cert.org/releases/${pkgname}-${pkgver}.tar.gz")
+md5sums=('46d5d0362581a09902b24635b4679b6a')
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}