summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2024-04-23 20:32:20 +0200
committerPeter Mattern2024-04-23 20:32:20 +0200
commit100898904a0498f50a4d19d46d7be72872d2d467 (patch)
treecc9508c14005181e9080a9ea09a7aaeed510636d
parent5f1f21cebffc0cf5df104b00ed8f0b31a475a497 (diff)
downloadaur-100898904a0498f50a4d19d46d7be72872d2d467.tar.gz
Miscellaneous updates
* upstream URL (homepage) * license string * dependencies * improve pkgver() * adjust header path
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e948f77087eb..fe699ef7b5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = libfm-qt-git
pkgdesc = Qt port of libfm, a library providing components to build desktop file managers
- pkgver = 1.3.0.5.gafc7189
+ pkgver = 2.0.0
pkgrel = 1
- url = https://github.com/lxqt/libfm-qt
+ url = https://lxqt-project.org
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL-2.1-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
- depends = qt5-x11extras
+ depends = qt6-base
depends = lxqt-menu-data-git
depends = menu-cache
depends = libexif
optdepends = gvfs: support for the trash bin and network devices
- provides = libfm-qt=1.3.0.5.gafc7189
+ provides = libfm-qt=2.0.0
conflicts = libfm-qt
conflicts = pcmanfm-qt<=0.10.0
source = git+https://github.com/lxqt/libfm-qt.git
diff --git a/PKGBUILD b/PKGBUILD
index daa2e202c466..59a26ecdfd97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
_pkgname=libfm-qt
pkgname=$_pkgname-git
-pkgver=1.3.0.5.gafc7189
+pkgver=2.0.0
pkgrel=1
pkgdesc='Qt port of libfm, a library providing components to build desktop file managers'
arch=('i686' 'x86_64')
-url='https://github.com/lxqt/libfm-qt'
-license=('LGPL')
-depends=('qt5-x11extras' 'lxqt-menu-data-git' 'menu-cache' 'libexif')
-makedepends=('git' 'cmake' 'qt5-tools' 'lxqt-build-tools-git')
+url="https://lxqt-project.org"
+license=("LGPL-2.1-only")
+depends=('qt6-base' 'lxqt-menu-data-git' 'menu-cache' 'libexif')
optdepends=(
'gvfs: support for the trash bin and network devices'
)
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname" 'pcmanfm-qt<=0.10.0')
source=('git+https://github.com/lxqt/libfm-qt.git')
@@ -21,14 +21,11 @@ sha256sums=('SKIP')
pkgver() {
cd $_pkgname
- git describe --always | sed 's:-:.:g'
-}
-
-prepare() {
- mkdir -p build
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {
+ mkdir -p build
cd build
cmake \
@@ -46,5 +43,5 @@ package() {
# CMake installs empty folders unexpectedly
# https://gitlab.kitware.com/cmake/cmake/issues/17122
- rmdir "$pkgdir"/usr/include/libfm-qt/{tests,translations}
+ rmdir "$pkgdir"/usr/include/libfm-qt6/{tests,translations}
}