summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten van Gompel2015-06-21 12:50:50 +0200
committerMaarten van Gompel2015-06-21 12:50:50 +0200
commit6b4b81474bfa036d12b0c1c359b9ebec6631f4a1 (patch)
tree26e82b6c1bdec3fac311e24d98fce3da7b1d6f89
downloadaur-6b4b81474bfa036d12b0c1c359b9ebec6631f4a1.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36ac9bb343a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libfolia
+ pkgdesc = C++ library for FoLiA (Format for Linguistic Annotation)
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://proycon.github.io/folia
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = libtool
+ makedepends = autoconf
+ depends = ticcutils
+ depends = icu
+ depends = libxml2
+ options = !libtool
+ source = http://software.ticc.uvt.nl/libfolia-0.13.tar.gz
+ md5sums = 9053c8eaefb83131d1f31eaccd844608
+
+pkgname = libfolia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..683fa0454ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy dot nl>
+pkgname=libfolia
+pkgver=0.13
+pkgrel=1
+pkgdesc="C++ library for FoLiA (Format for Linguistic Annotation)"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('ticcutils' 'icu' 'libxml2')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+url="http://proycon.github.io/folia"
+source=("http://software.ticc.uvt.nl/$pkgname-$pkgver.tar.gz")
+md5sums=('9053c8eaefb83131d1f31eaccd844608')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}