summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea De Bellis2024-04-02 13:21:46 +0200
committerAndrea De Bellis2024-04-02 13:21:46 +0200
commitc1d64feb384abc82f343269e4dae767e8eb3ee32 (patch)
treee432dd35acfafa544d3b3a2a1dea61887f018719
downloadaur-c1d64feb384abc82f343269e4dae767e8eb3ee32.tar.gz
Upload edited PKGBUILD from libfprint-elanmoc2-git to support the new branch, elanmoc2-working.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8a13e5f7e5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libfprint-elanmoc2-working-git
+ pkgdesc = Library for fingerprint readers with patches for the support of the ELAN 0C4C & 0C00.
+ pkgver = 1.94.0+276+g3d489eb
+ pkgrel = 1
+ url = https://fprint.freedesktop.org/
+ arch = x86_64
+ groups = fprint
+ license = LGPL
+ checkdepends = cairo
+ makedepends = git
+ makedepends = meson
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ depends = libgusb
+ depends = pixman
+ depends = nss
+ depends = systemd
+ depends = libgudev
+ provides = libfprint=1.94.0
+ provides = libfprint-2.so
+ conflicts = libfprint
+ source = git+https://gitlab.freedesktop.org/Depau/libfprint.git#branch=elanmoc2-working
+ sha256sums = SKIP
+
+pkgname = libfprint-elanmoc2-working-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad62e34aad57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Mantainer: Andrea De Bellis <spiralprojectss@gmail.com>
+# Contributor: Johnathon Clark <john.clark at cantab dot net> (Original Author)
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+
+# This is a build of the experimental elanmoc2 driver by Davide Depau
+
+pkgname=libfprint-elanmoc2-working-git
+_pkgname=libfprint
+pkgver=1.94.0+276+g3d489eb
+pkgrel=1
+pkgdesc="Library for fingerprint readers with patches for the support of the ELAN 0C4C & 0C00."
+url="https://fprint.freedesktop.org/"
+arch=(x86_64)
+license=(LGPL)
+depends=(libgusb pixman nss systemd libgudev)
+makedepends=(git meson gtk-doc gobject-introspection)
+checkdepends=(cairo)
+conflicts=(libfprint)
+provides=(libfprint=1.94.0 libfprint-2.so)
+groups=(fprint)
+source=("git+https://gitlab.freedesktop.org/Depau/libfprint.git#branch=elanmoc2-working")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/^v//;s/^V_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+}
+
+build() {
+ arch-meson $_pkgname build
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}