summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlireza |S.N|2022-11-11 11:38:56 +0330
committerAlireza |S.N|2022-11-11 11:38:56 +0330
commitd6e6f793b6f5074b105ee09f6ac6040c0569c2d4 (patch)
treee9633e3aa9d29e60bbfe3e3741c94395fd2df95c
downloadaur-d6e6f793b6f5074b105ee09f6ac6040c0569c2d4.tar.gz
Add PKGBUILD for libfprint goodixtls 55x4 driver
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD38
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4055293e59cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = libfprint-goodixtls-55x4
+ pkgdesc = libfprint fork for goodixtls 55x4 devices. Currently supports 55b4 and 55a4. Note you will need to flash your device with [goodix-fp-dump](https://github.com/mpi3d/goodix-fp-dump) to use this
+ pkgver = r1710.1033241
+ pkgrel = 1
+ arch = x86_64
+ license = LGPL2
+ makedepends = git
+ makedepends = meson
+ makedepends = opencv
+ makedepends = pkgconf
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = doctest
+ depends = libgusb
+ depends = openssl
+ depends = pixman
+ depends = nss
+ depends = libgudev
+ optdepends = fprintd: D-Bus daemon for managing readers
+ provides = libfprint
+ provides = libfprint-2.so=2-64
+ conflicts = libfprint
+ source = libfprint-goodixtls-55x4::git+https://github.com/TheWeirdDev/libfprint.git
+ md5sums = SKIP
+
+pkgname = libfprint-goodixtls-55x4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8f43a119f73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alireza S.N. <alireza6677@gmail.com>
+
+arch=('x86_64')
+pkgname="libfprint-goodixtls-55x4"
+pkgdesc="libfprint fork for goodixtls 55x4 devices. Currently supports 55b4 and 55a4. Note you will need to flash your device with [goodix-fp-dump](https://github.com/mpi3d/goodix-fp-dump) to use this"
+makedepends=("git" "meson" "opencv" "pkgconf" "gobject-introspection" "gtk-doc" "doctest")
+license=("LGPL2")
+provides=("libfprint" "libfprint-2.so=2-64")
+conflicts=("libfprint")
+source=("${pkgname}::git+https://github.com/TheWeirdDev/libfprint.git")
+pkgrel=1
+pkgver=r1710.1033241
+md5sums=('SKIP')
+depends=('libgusb' 'openssl' 'pixman' 'nss' 'libgudev')
+optdepends=('fprintd: D-Bus daemon for managing readers')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ git switch '55b4-experimental'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/build"
+ meson ..
+ meson configure --buildtype=release --prefix=/usr -D doc=false
+ meson build ..
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ meson install --destdir="${pkgdir}"
+}