summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-06-02 21:43:49 +0000
committerDaniel Bermond2020-06-02 21:43:57 +0000
commitcb13e2fb130f37d008fadd1e069e4a07253878ea (patch)
tree387da3cb89d9256a2d4b10a8184a4e8c08e6dba8
parent9a7688cb9a0bc5a11b64af0b59796d2d5d899983 (diff)
downloadaur-cb13e2fb130f37d008fadd1e069e4a07253878ea.tar.gz
Fix build with gcc10
-rw-r--r--.SRCINFO6
-rw-r--r--010-libfpx-gcc10-fix.patch8
-rwxr-xr-xPKGBUILD39
3 files changed, 29 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7dccbe06948..30241a4529c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = libfpx
pkgdesc = FlashPIX OpenSource Toolkit
pkgver = 1.3.1.10
- pkgrel = 3
- url = https://www.imagemagick.org/download/delegates/
+ pkgrel = 4
+ url = https://github.com/ImageMagick/libfpx/
arch = x86_64
license = custom
depends = gcc-libs
source = https://www.imagemagick.org/download/delegates/libfpx-1.3.1-10.tar.xz
+ source = 010-libfpx-gcc10-fix.patch
sha256sums = 491b55535580d27355669c45fe995446bd34df5dbcdc15312e58c3ebecc6a455
+ sha256sums = e93f193b199023c5e2e2557c4f21fc276b8784f5a07363729235c42c16066cbd
pkgname = libfpx
diff --git a/010-libfpx-gcc10-fix.patch b/010-libfpx-gcc10-fix.patch
new file mode 100644
index 000000000000..2d9a5c1d1200
--- /dev/null
+++ b/010-libfpx-gcc10-fix.patch
@@ -0,0 +1,8 @@
+--- a/jpeg/ejpeg.h
++++ b/jpeg/ejpeg.h
+@@ -32,4 +32,4 @@
+ #define IMG_FORMAT_411 0x05 /* Three-component 4:1:1 image */
+
+ JPEGEXPORT
+-int No_JPEG_Header_Flag;
++extern int No_JPEG_Header_Flag;
diff --git a/PKGBUILD b/PKGBUILD
index 705764f5be7d..55176bc3c39e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,45 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=libfpx
pkgver=1.3.1.10
_srcver="$(printf '%s' "$pkgver" | sed -E s'/(\.)([0-9]*)$/-\2/')"
-pkgrel=3
+pkgrel=4
pkgdesc='FlashPIX OpenSource Toolkit'
arch=('x86_64')
-url='https://www.imagemagick.org/download/delegates/'
+url='https://github.com/ImageMagick/libfpx/'
license=('custom')
depends=('gcc-libs')
-source=("https://www.imagemagick.org/download/delegates/${pkgname}-${_srcver}.tar.xz")
-sha256sums=('491b55535580d27355669c45fe995446bd34df5dbcdc15312e58c3ebecc6a455')
+source=("https://www.imagemagick.org/download/delegates/${pkgname}-${_srcver}.tar.xz"
+ '010-libfpx-gcc10-fix.patch')
+sha256sums=('491b55535580d27355669c45fe995446bd34df5dbcdc15312e58c3ebecc6a455'
+ 'e93f193b199023c5e2e2557c4f21fc276b8784f5a07363729235c42c16066cbd')
prepare() {
- cd "${pkgname}-${_srcver}"
-
- # create a "LICENSE" file (note: license is in the file 'flashpix.h')
- cp -af flashpix.h LICENSE
+ # create a 'LICENSE' file (note: license is in the file 'flashpix.h')
+ cp -af "${pkgname}-${_srcver}"/{flashpix.h,LICENSE}
# erase characters denoting comments
- sed -i '1s/^.\{,3\}//' LICENSE
- sed -i '2,79s/^.\{,2\}//' LICENSE
- sed -i '80s/^.\{,3\}//' LICENSE
+ sed -i '1s/^.\{,3\}//' "${pkgname}-${_srcver}/LICENSE"
+ sed -i '2,79s/^.\{,2\}//' "${pkgname}-${_srcver}/LICENSE"
+ sed -i '80s/^.\{,3\}//' "${pkgname}-${_srcver}/LICENSE"
+
+ patch -d "${pkgname}-${_srcver}" -Np1 -i "${srcdir}/010-libfpx-gcc10-fix.patch"
}
build() {
cd "${pkgname}-${_srcver}"
-
./configure \
--prefix='/usr' \
--enable-static='no' \
--enable-shared='yes'
-
make
}
check() {
- cd "${pkgname}-${_srcver}"
-
- make check
+ make -C "${pkgname}-${_srcver}" check
}
package() {
- cd "${pkgname}-${_srcver}"
-
- make DESTDIR="$pkgdir" install
-
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ make -C "${pkgname}-${_srcver}" DESTDIR="$pkgdir" install
+ install -D -m644 "${pkgname}-${_srcver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}