summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Peppard2022-10-17 16:58:07 +0100
committerGeorge Peppard2022-10-17 16:58:07 +0100
commit5b66295752a4d01fc8afa2561bc799513b82e595 (patch)
tree460a456cdd7dc4406d4ee52ae4c73a373ecea92e
downloadaur-5b66295752a4d01fc8afa2561bc799513b82e595.tar.gz
add libfsm-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63340413b0ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libfsm-git
+ pkgdesc = DFA regular expression library & friends
+ pkgver = r2867.6038ae4f
+ pkgrel = 1
+ url = https://github.com/katef/libfsm
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = bmake
+ makedepends = libxslt
+ makedepends = docbook-xsl
+ makedepends = docbook-xml
+ depends = glibc
+ provides = libfsm
+ source = git+https://github.com/katef/libfsm.git
+ md5sums = SKIP
+
+pkgname = libfsm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80fb3bd74ae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: George Peppard <gjp1g21 at soton dot ac dot uk>
+pkgname=libfsm-git
+pkgver=r2867.6038ae4f
+pkgrel=1
+arch=('x86_64')
+pkgdesc="DFA regular expression library & friends"
+url="https://github.com/katef/libfsm"
+license=('BSD')
+depends=(glibc)
+makedepends=(git bmake libxslt docbook-xsl docbook-xml)
+provides=(libfsm)
+source=('git+https://github.com/katef/libfsm.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/libfsm"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare () {
+ cd "$srcdir/libfsm"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/libfsm"
+ bmake -r
+}
+
+package () {
+ cd "$srcdir/libfsm"
+ PREFIX="$pkgdir/usr" bmake -r install
+ mv "$pkgdir/usr/man" "$pkgdir/usr/share/man"
+ install -Dm644 LICENCE "$pkgdir/usr/share/licenses/libfsm-git/LICENSE"
+} \ No newline at end of file