summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-02-23 12:05:43 -0500
committerJames An2016-02-23 12:05:43 -0500
commitb6402860d419e50d0e265591404e9e1e80f36647 (patch)
treee518783be7d13eeb817da09ecb9fa8a23d9bf3f1
downloadaur-b6402860d419e50d0e265591404e9e1e80f36647.tar.gz
Initial commit with working PKGBUILD.
-rw-r--r--.SRCINFO21
-rwxr-xr-x.gitignore27
-rw-r--r--PKGBUILD53
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39388068ba7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Feb 23 17:05:17 UTC 2016
+pkgbase = libfvde-git
+ pkgdesc = Library and tools to access FileVault Drive Encryption (FVDE) encrypted volumes
+ pkgver = 20151013.r6.g82c2461
+ pkgrel = 1
+ url = https://github.com/libyal/libfvde/wiki
+ arch = i686
+ arch = x86_64
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = libxml2
+ depends = openssl
+ provides = libfvde=20151013.r6.g82c2461
+ conflicts = libfvde
+ source = libfvde::git+https://github.com/libyal/libfvde.git
+ md5sums = SKIP
+
+pkgname = libfvde-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edc7db62462d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=libfvde-git
+_pkgname=${pkgname%-git}
+pkgver=20151013.r6.g82c2461
+pkgrel=1
+pkgdesc='Library and tools to access FileVault Drive Encryption (FVDE) encrypted volumes'
+arch=('i686' 'x86_64' 'any')
+url="https://github.com/libyal/$_pkgname/wiki"
+license=('LGPL3')
+depends=('libxml2' 'openssl')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=()
+install=
+source=("$_pkgname"::"git+https://github.com/libyal/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ ./synclibs.sh
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$_pkgname"
+
+ make -k check
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}