summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Maguire2015-10-20 19:37:27 -0400
committerJohn Maguire2015-10-20 19:37:27 -0400
commit99b78eca73114507bbb94a8ab31a70a1bb0da01a (patch)
tree5f47c529f5ec47c3b7764b893c9e0f4160906aef
downloadaur-99b78eca73114507bbb94a8ab31a70a1bb0da01a.tar.gz
Add initial libfxqllauncher package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--libfxqllauncher.install0
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4aeb436049c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libfxqllauncher
+ pkgdesc = QuakeLive Launcher C++ Library and QML Plugin
+ pkgver = 0.1.0.6765890
+ pkgrel = 2
+ url = https://bitbucket.org/fx_/fx-qllauncher
+ install = libfxqllauncher.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-declarative
+ depends = boost>=1.55
+ depends = qt5-base<5.5
+ depends = quazip-qt5
+ depends = qxmpp
+ source = libfxqllauncher::git+https://bitbucket.org/fx_/fx-qllauncher.git
+ sha256sums = SKIP
+
+pkgname = libfxqllauncher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea6a8858d132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: John Maguire <contact@johnmaguire.me>
+pkgname=libfxqllauncher
+pkgver=0.1.0.6765890
+pkgrel=2
+pkgdesc="QuakeLive Launcher C++ Library and QML Plugin"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fx_/fx-qllauncher"
+license=('GPL3')
+depends=('boost>=1.55' 'qt5-base<5.5' 'quazip-qt5' 'qxmpp')
+makedepends=('git' 'qt5-declarative')
+install="$pkgname.install"
+source=("$pkgname::git+https://bitbucket.org/fx_/fx-qllauncher.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+ # Using 0.1.0 as a stand-in for lack of versioning
+ echo 0.1.0.$(git log -1 --format="%h")
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+
+ # Debian quazip-qt5 is Arch quazip5
+ sed -i 's/quazip-qt5/quazip5/g' ./fxqllauncher/fxqllauncher.pro
+
+ # Similarly, includes are quazip5, not plain quazip
+ find ./ -type f -exec sed -i -e 's/#include <quazip\//#include <quazip5\//g' {} \;
+}
+
+build() {
+ cd "$srcdir/$pkgname/fxqllauncher"
+ qmake fxqllauncher.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/fxqllauncher"
+ make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+}
diff --git a/libfxqllauncher.install b/libfxqllauncher.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/libfxqllauncher.install