summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Maguire2015-10-20 19:35:27 -0400
committerJohn Maguire2015-10-20 19:35:27 -0400
commit4bc3c013df5983b9531764f6132bca6221ad6aba (patch)
treee82f8d8586969c46d110b939b19e5e1bccecccba
downloadaur-4bc3c013df5983b9531764f6132bca6221ad6aba.tar.gz
Add initial libfxqmlcontrols package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--libfxqmlcontrols.install0
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc6c7547240b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libfxqmlcontrols
+ pkgdesc = QML Controls library from FX
+ pkgver = 0.1.0.233fbcb
+ pkgrel = 1
+ url = https://bitbucket.org/fx_/fx-qml-controls
+ install = libfxqmlcontrols.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ source = libfxqmlcontrols::git+https://bitbucket.org/fx_/fx-qml-controls.git
+ sha256sums = SKIP
+
+pkgname = libfxqmlcontrols
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83dac2cdfe5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: John Maguire <contact@johnmaguire.me>
+pkgname=libfxqmlcontrols
+pkgver=0.1.0.233fbcb
+pkgrel=1
+pkgdesc="QML Controls library from FX"
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fx_/fx-qml-controls"
+license=('GPL3')
+makedepends=('git')
+install="$pkgname.install"
+source=("$pkgname::git+https://bitbucket.org/fx_/fx-qml-controls.git")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo 0.1.0.$(git log -1 --format="%h")
+}
+
+build() {
+ cd "$srcdir/$pkgname/fxqmlcontrols"
+ qmake fxqmlcontrols.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/fxqmlcontrols"
+ make DESTDIR="$pkgdir" INSTALL_ROOT="$pkgdir" install
+}
diff --git a/libfxqmlcontrols.install b/libfxqmlcontrols.install
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/libfxqmlcontrols.install