summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2021-01-07 22:02:11 +0100
committerMorten Linderud2021-01-07 22:02:11 +0100
commit94793b806948c74438d52fb50a21a1556170fe55 (patch)
tree19ee39ffb38cd451a2731eaaa7a7377a1818da13
downloadaur-94793b806948c74438d52fb50a21a1556170fe55.tar.gz
import from community
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90a2d4d945e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libg15
+ pkgdesc = Provides low-level access to the Logitech G15 and G11 keyboards and Z10 speakers
+ pkgver = 1.2.7
+ pkgrel = 4
+ url = http://www.g15tools.com/
+ arch = x86_64
+ license = GPL
+ depends = libusb-compat
+ source = https://downloads.sourceforge.net/g15tools/libg15-1.2.7.tar.bz2
+ sha512sums = ddffb38f5c3d9ce0cb90b0375c2f5d317a7bb3889fe59d56932a0889c6e15bc2f1e590757d3182eddf7c5bd3101303b332b18fbd37247c20f66e1be256aa93c0
+
+pkgname = libg15
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e4837c8668b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Evgeniy Alekseev <arcanis.arch at gmail dot com>
+# Contributor: onestep_ua <onestep at ukr dot net>
+
+pkgname=libg15
+pkgver=1.2.7
+pkgrel=4
+pkgdesc="Provides low-level access to the Logitech G15 and G11 keyboards and Z10 speakers"
+arch=('x86_64')
+url="http://www.g15tools.com/"
+license=('GPL')
+depends=('libusb-compat')
+source=(https://downloads.sourceforge.net/g15tools/${pkgname}-${pkgver}.tar.bz2)
+sha512sums=('ddffb38f5c3d9ce0cb90b0375c2f5d317a7bb3889fe59d56932a0889c6e15bc2f1e590757d3182eddf7c5bd3101303b332b18fbd37247c20f66e1be256aa93c0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}