summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Nielsen2015-06-27 19:44:22 +1000
committerAdam Nielsen2015-06-27 19:44:22 +1000
commit79f7e727276ce2cd210396ca656fbd0ab857172c (patch)
tree42f57854750554aaab861463531a538ee9cc9fa6
downloadaur-libgamegraphics-git.tar.gz
Import to AUR4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD63
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0b01f2644de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libgamegraphics-git
+ pkgdesc = Access and modify images, sprites and animations from many different games
+ pkgver = 20120611
+ pkgrel = 1
+ url = http://www.shikadi.net/camoto
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = pkgconfig
+ depends = boost
+ depends = libgamecommon
+ depends = png++
+ provides = libgamegraphics
+ conflicts = libgamegraphics
+
+pkgname = libgamegraphics-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68c98acff378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Adam Nielsen <malvineous@shikadi.net>
+
+_pkgname=libgamegraphics
+pkgname=${_pkgname}-git
+pkgver=20120611
+pkgrel=1
+pkgdesc="Access and modify images, sprites and animations from many different games"
+arch=('i686' 'x86_64')
+url="http://www.shikadi.net/camoto"
+license=('GPL3')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=('boost' 'libgamecommon' 'png++')
+makedepends=('git' 'autoconf' 'automake' 'pkgconfig')
+options=()
+_gitname=${_pkgname}
+_gitroot="git://github.com/Malvineous/${_gitname}"
+source=()
+md5sums=()
+
+build() {
+ cd "${srcdir}"
+
+ if [ "$NOEXTRACT" -eq 0 ]; then
+ if [ -d "$_gitname" ]; then
+ cd "$_gitname"
+
+ msg "Cleaning up from previous build."
+ git clean -X -f
+
+ msg "Reverting local changes to source tree..."
+ git reset --hard
+
+ msg "Updating from GitHub server..."
+ git pull origin
+ msg "The local files are updated."
+ else
+ msg "Downloading from GitHub server..."
+ git clone --depth=1 -- "$_gitroot" "$_gitname"
+ cd "$_gitname"
+ fi
+ else
+ warning "Skipping git clean/pull -- using existing src/ tree"
+ cd "$_gitname"
+ fi
+
+ msg "Configuring build environment..."
+ ./autogen.sh
+ ./configure --prefix="/usr"
+
+ msg "Beginning compile..."
+ make ${MAKEFLAGS}
+}
+
+check() {
+ cd "$srcdir/$_gitname"
+ make ${MAKEFLAGS} check
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install DESTDIR="$pkgdir"
+}