summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-04-17 18:36:00 +0000
committerDaniel Bermond2021-04-17 18:36:00 +0000
commitcb7540fa077a435d8cf2b6206675fe8e3627635a (patch)
treebc1264d59febccf287dfd5df9516e29aedd188a8
parent538ceaa668c2cd4aa34a63da2310062cf66c2d06 (diff)
downloadaur-cb7540fa077a435d8cf2b6206675fe8e3627635a.tar.gz
Update to version 0.16.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 694b12ab5fc6..48fc3b557ef2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = libgav1
pkgdesc = A main profile (0) and high profile (1) compliant AV1 decoder
- pkgver = 0.16.0
- pkgrel = 2
+ pkgver = 0.16.3
+ pkgrel = 1
url = https://chromium.googlesource.com/codecs/libgav1/
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
depends = gcc-libs
- source = git+https://chromium.googlesource.com/codecs/libgav1#tag=v0.16.0
- source = git+https://github.com/abseil/abseil-cpp.git#tag=20200225.2
+ source = git+https://chromium.googlesource.com/codecs/libgav1#tag=v0.16.3
+ source = git+https://github.com/abseil/abseil-cpp.git#tag=20210324.0
+ source = git+https://github.com/google/googletest.git#tag=release-1.10.0
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ab8f0e0e376d..237eac11093b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
-_abseil_ver=20200225.2
-
pkgname=libgav1
-pkgver=0.16.0
-pkgrel=2
+pkgver=0.16.3
+pkgrel=1
pkgdesc='A main profile (0) and high profile (1) compliant AV1 decoder'
arch=('x86_64')
url='https://chromium.googlesource.com/codecs/libgav1/'
license=('Apache')
depends=('gcc-libs')
makedepends=('git' 'cmake')
+_abseil_ver=20210324.0
+_gtest_ver=1.10.0
source=("git+https://chromium.googlesource.com/codecs/libgav1#tag=v${pkgver}"
- "git+https://github.com/abseil/abseil-cpp.git#tag=${_abseil_ver}")
+ "git+https://github.com/abseil/abseil-cpp.git#tag=${_abseil_ver}"
+ "git+https://github.com/google/googletest.git#tag=release-${_gtest_ver}")
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
prepare() {
mkdir -p libgav1/third_party
ln -sf ../../abseil-cpp libgav1/third_party/abseil-cpp
+ ln -sf ../../googletest libgav1/third_party/googletest
}
build() {
@@ -26,10 +29,19 @@ build() {
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DLIBGAV1_ENABLE_SSE4_1:BOOL='OFF' \
+ -DLIBGAV1_ENABLE_AVX2:BOOL='OFF' \
-Wno-dev
make -C build
}
+check() {
+ local _test
+ while read -r -d '' _test
+ do
+ "$_test"
+ done < <(find build -maxdepth 1 -type f -name '*_test' -executable -print0)
+}
+
package() {
make -C build DESTDIR="$pkgdir" install
}