summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-04-09 01:42:23 +0200
committerCarsten Teibes2014-04-09 01:42:23 +0200
commitcf8e97236efba3dfcb3df09c6e09871df5b0ba7a (patch)
tree61aec82fbb0437cafa3d1f5a803a7fca921ad032
downloadaur-cf8e97236efba3dfcb3df09c6e09871df5b0ba7a.tar.gz
[add] libgba 20090222
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17f17166405e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libgba
+ pkgdesc = Library for Nintendo Gameboy Advance homebrew development
+ pkgver = 20090222
+ pkgrel = 2
+ url = http://www.devkitpro.org
+ arch = any
+ license = GPL
+ license = LGPL
+ depends = devkitarm
+ noextract = gba-examples-20090222.tar.bz2
+ options = !strip
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/devkitpro/libgba-src-20090222.tar.bz2
+ source = http://downloads.sourceforge.net/sourceforge/devkitpro/gba-examples-20090222.tar.bz2
+ sha256sums = 9d85b64b323a5f2e8f8ec46ba8cb76ae3921e4b75b54d3b51b84a44fe41fc57a
+ sha256sums = 10759af863d4222857f98867571b8f5bf4328d44446c7b4384cd3f029bc10753
+
+pkgname = libgba
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35190a7579d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: demonicmaniac <demonicmaniac@gmx.net>
+# Contributor: TheGuy <lowelink26381@gmail.com>
+# Contributor: Nicolas Hureau <archlinux@kalenz.fr>
+
+pkgname=libgba
+pkgver=20090222
+_pkgverexamples=20090222
+pkgrel=2
+pkgdesc="Library for Nintendo Gameboy Advance homebrew development"
+arch=('any')
+url="http://www.devkitpro.org"
+license=('GPL' 'LGPL')
+depends=('devkitarm')
+options=(!strip staticlibs)
+source=("http://downloads.sourceforge.net/sourceforge/devkitpro/$pkgname-src-$pkgver.tar.bz2"
+ "http://downloads.sourceforge.net/sourceforge/devkitpro/gba-examples-$_pkgverexamples.tar.bz2")
+sha256sums=('9d85b64b323a5f2e8f8ec46ba8cb76ae3921e4b75b54d3b51b84a44fe41fc57a'
+ '10759af863d4222857f98867571b8f5bf4328d44446c7b4384cd3f029bc10753')
+noextract=("gba-examples-$_pkgverexamples.tar.bz2")
+
+build() {
+ source /etc/profile.d/devkitarm.sh
+ make
+}
+
+package() {
+ export DEVKITPRO="$pkgdir/opt/devkitpro"
+
+ make install
+ # examples
+ install -d "$DEVKITPRO"/examples/gba
+ bsdtar -x -f gba-examples-$_pkgverexamples.tar.bz2 -C "$DEVKITPRO"/examples/gba
+ # fix permissions
+ chown -R root:root "$DEVKITPRO"/examples
+ find "$DEVKITPRO"/examples -type d -exec chmod +rx "{}" \+
+ # license
+ install -Dm644 libgba_license.txt "$pkgdir"/usr/share/licenses/libgba/libgba_license.txt
+}