summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Bruhin2016-08-09 09:31:31 +0200
committerFlorian Bruhin2016-08-09 09:31:31 +0200
commitf1b1b681174e0cbf094c0dffc9a9208d0f86dfdb (patch)
treee81503cf09c65bd2fa6f7c606034d257c9c6600c
downloadaur-f1b1b681174e0cbf094c0dffc9a9208d0f86dfdb.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8e9585f3f98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Aug 9 07:28:46 UTC 2016
+pkgbase = libgcj17-bin
+ pkgdesc = Dynamically load and interpret java class files. Built from binary executables available in Debian repositories.
+ pkgver = 6.1.1_11
+ pkgrel = 1
+ url = http://gcc.gnu.org/java/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ conflicts = gcc-gcj
+ source_i686 = http://httpredir.debian.org/debian/pool/main/g/gcc-6/libgcj17_6.1.1-11_i386.deb
+ sha1sums_i686 = 38ad62c1e43283d07b22a4a2cc610e330a312e0e
+ source_x86_64 = http://httpredir.debian.org/debian/pool/main/g/gcc-6/libgcj17_6.1.1-11_amd64.deb
+ sha1sums_x86_64 = 47558fb0fa03a8563ca8dee3d92cfea4412b57a1
+
+pkgname = libgcj17-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..78e6924c3fc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#!/bin/bash
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+# Contributor: Yannik Stein <yannik.stein [at] gmail.com>
+# Contributor: Roberto Calabrese <robertocalabrese75 [at] gmail.com>
+
+pkgname=libgcj17-bin
+pkgver=6.1.1_11
+pkgrel=1
+pkgdesc="Dynamically load and interpret java class files. Built from binary \
+executables available in Debian repositories."
+url=http://gcc.gnu.org/java/
+arch=(i686 x86_64)
+license=(GPL)
+conflicts=(gcc-gcj)
+depends=(zlib)
+
+source_i686=(http://httpredir.debian.org/debian/pool/main/g/gcc-6/${pkgname%-*}_${pkgver%_*}-${pkgver##*_}_i386.deb)
+source_x86_64=(http://httpredir.debian.org/debian/pool/main/g/gcc-6/${pkgname%-*}_${pkgver%_*}-${pkgver##*_}_amd64.deb)
+sha1sums_i686=('38ad62c1e43283d07b22a4a2cc610e330a312e0e')
+sha1sums_x86_64=('47558fb0fa03a8563ca8dee3d92cfea4412b57a1')
+
+prepare() {
+ tar xf data.tar.*
+}
+
+package() {
+ find -type f -name 'libgcj.so*' \
+ -execdir install -Dm755 {} "$pkgdir/usr/lib/{}" \;
+}
+
+# vim:set ts=2 sw=2 et: