summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:57:09 +0200
committerLubosz Sarnecki2015-06-22 22:57:09 +0200
commit571464cb84dec40adc3bb4832a188f0e77606e72 (patch)
tree23ee38d03e3fb3c032d7d3279215379603096ee2
downloadaur-571464cb84dec40adc3bb4832a188f0e77606e72.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD49
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc1add95ff96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libgee-git
+ pkgdesc = GObject collection library
+ pkgver = 0.12.0.428.f71b18a
+ pkgrel = 1
+ url = http://live.gnome.org/Libgee
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = gobject-introspection
+ makedepends = vala
+ makedepends = gnome-common
+ depends = glib2
+ provides = libgee=0.12.0.428.f71b18a
+ conflicts = libgee
+ source = git+git://git.gnome.org/libgee
+ sha256sums = SKIP
+
+pkgname = libgee-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7003230520d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id: PKGBUILD 198163 2013-10-30 13:10:44Z allan $
+# Original Package : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+pkgname=libgee-git
+pkgver=0.12.0.428.f71b18a
+pkgrel=1
+pkgdesc="GObject collection library"
+url="http://live.gnome.org/Libgee"
+license=(LGPL2.1)
+arch=(i686 x86_64)
+depends=(glib2)
+makedepends=(gobject-introspection vala gnome-common)
+
+provides=('libgee='$pkgver)
+conflicts=('libgee')
+
+source='git+git://git.gnome.org/libgee'
+sha256sums=('SKIP')
+
+_gitname='libgee'
+
+pkgver() {
+ cd $_gitname
+ version=$(grep AC_INIT configure.ac | sed 's/AC_INIT(\[libgee\], \[//' | sed 's/\], \[https:\/\/bugzilla.gnome.org\/enter_bug.cgi?product=libgee\], \[libgee\])//')
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+
+ echo $version.$revision.$hash
+}
+
+build() {
+ cd $_gitname
+ ./autogen.sh --prefix=/usr --disable-static
+ make
+}
+
+check() {
+ cd $_gitname
+ # generates a bazillion traps - make sure systemd's core_pattern
+ # is deactivated, or you'll DoS the journal and the system
+ #make check
+}
+
+package() {
+ cd $_gitname
+ make DESTDIR="$pkgdir" install
+}