summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2024-03-12 16:28:41 +0200
committerEvert Vorster2024-03-12 16:28:41 +0200
commit113a320c136417ebf2f9bf5b032386186f29f55c (patch)
treee56ba7f67f2064636d4e2d69606adfe65a718a2b
downloadaur-113a320c136417ebf2f9bf5b032386186f29f55c.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad100fe23ac6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libgeotiff-git
+ pkgdesc = Permits the extraction of keys from geotiff files, cmake version
+ pkgver = 1.7.1_44_g1f3e10b
+ pkgrel = 1
+ url = https://github.com/OSGeo/libgeotiff
+ arch = x86_64
+ license = MIT
+ depends = libtiff
+ depends = proj
+ provides = libgeotiff
+ conflicts = libgeotiff
+ source = git+https://github.com/OSGeo/libgeotiff
+ sha256sums = SKIP
+
+pkgname = libgeotiff-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a478c3f2ca37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Evert Vorster <superchief AT evertvorster DOT com>
+pkgname=libgeotiff-git
+_pkgname=libgeotiff
+pkgver=1.7.1_44_g1f3e10b
+pkgrel=1
+epoch=
+pkgdesc="Permits the extraction of keys from geotiff files, cmake version"
+arch=(x86_64)
+url="https://github.com/OSGeo/libgeotiff"
+license=('MIT')
+groups=()
+depends=(libtiff proj)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(libgeotiff)
+conflicts=(libgeotiff)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/OSGeo/libgeotiff")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver(){
+ cd "$srcdir/$_pkgname/"
+ git describe --tags | tr - _
+}
+
+prepare() {
+echo "Prepare step"
+}
+
+build() {
+echo "Build step"
+cd ${srcdir}/${_pkgname}
+mkdir -p build_cmake
+cd build_cmake
+cmake -DCMAKE_C_COMPILER_LAUNCHER=ccache -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_FLAGS="-Wall -Wextra -Werror" ../libgeotiff
+make -j3
+
+}
+
+check() {
+echo "Check step"
+# cd "$pkgname-$pkgver"
+# make -k check
+}
+
+package() {
+# cd "$pkgname-$pkgver"
+ cd ${srcdir}/${_pkgname}/build_cmake
+ cp ../libgeotiff/LICENSE .
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+}