summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-04-23 11:44:23 +0200
committerBartłomiej Piotrowski2018-04-23 11:44:23 +0200
commit3ac97fa371b4e038b2301174b80254b773555d26 (patch)
tree6e3122e97fb32f22dbbe04a82dca81414f952c52
downloadaur-3ac97fa371b4e038b2301174b80254b773555d26.tar.gz
Move from [extra]
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD62
-rw-r--r--libgksu-2.0.0-fbsd.patch60
-rw-r--r--libgksu-2.0.12-automake-1.11.2.patch25
-rw-r--r--libgksu-2.0.12-fix-make-3.82.patch19
-rw-r--r--libgksu-2.0.12-notests.patch26
-rw-r--r--libgksu-2.0.12-revert-forkpty.patch359
-rw-r--r--libgksu-2.0.7-libs.patch76
-rw-r--r--libgksu-2.0.7-polinguas.patch40
9 files changed, 701 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca89dc93310c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = libgksu
+ pkgdesc = gksu authorization library
+ pkgver = 2.0.12
+ pkgrel = 8
+ url = http://www.nongnu.org/gksu/index.html
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = gtk-doc
+ depends = gconf
+ depends = gtk2
+ depends = libgnome-keyring
+ depends = libgtop
+ depends = startup-notification
+ options = !emptydirs
+ source = http://people.debian.org/~kov/gksu/libgksu-2.0.12.tar.gz
+ source = libgksu-2.0.0-fbsd.patch
+ source = libgksu-2.0.12-automake-1.11.2.patch
+ source = libgksu-2.0.12-fix-make-3.82.patch
+ source = libgksu-2.0.12-notests.patch
+ source = libgksu-2.0.12-revert-forkpty.patch
+ source = libgksu-2.0.7-libs.patch
+ source = libgksu-2.0.7-polinguas.patch
+ md5sums = c7154c8806f791c10e7626ff123049d3
+ md5sums = 063a2b45d8e7cbba898d1db413242da0
+ md5sums = 2eeb34ad9b5bf29e8e2ebf8c8a5a28b6
+ md5sums = afeaf5caab03d793258d62d60a9bf0f0
+ md5sums = 4179d0487d6032e56b8a925010694c0a
+ md5sums = aebbe57e5286c654e27cf714cf3b704a
+ md5sums = 58d3a4a9d2ac741951720043ea3f7b5f
+ md5sums = 0b5c3d5d9b32cb3e65d9f0bfbcb11a76
+
+pkgname = libgksu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..066c119482de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 310007 2017-11-15 14:11:34Z foutrelis $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libgksu
+pkgver=2.0.12
+pkgrel=8
+pkgdesc="gksu authorization library"
+arch=(x86_64)
+url="http://www.nongnu.org/gksu/index.html"
+license=(GPL)
+depends=('gconf' 'gtk2' 'libgnome-keyring' 'libgtop' 'startup-notification')
+makedepends=('intltool' 'gtk-doc')
+options=('!emptydirs')
+source=(http://people.debian.org/~kov/gksu/${pkgname}-${pkgver}.tar.gz
+ libgksu-2.0.0-fbsd.patch
+ libgksu-2.0.12-automake-1.11.2.patch
+ libgksu-2.0.12-fix-make-3.82.patch
+ libgksu-2.0.12-notests.patch
+ libgksu-2.0.12-revert-forkpty.patch
+ libgksu-2.0.7-libs.patch
+ libgksu-2.0.7-polinguas.patch)
+md5sums=('c7154c8806f791c10e7626ff123049d3'
+ '063a2b45d8e7cbba898d1db413242da0'
+ '2eeb34ad9b5bf29e8e2ebf8c8a5a28b6'
+ 'afeaf5caab03d793258d62d60a9bf0f0'
+ '4179d0487d6032e56b8a925010694c0a'
+ 'aebbe57e5286c654e27cf714cf3b704a'
+ '58d3a4a9d2ac741951720043ea3f7b5f'
+ '0b5c3d5d9b32cb3e65d9f0bfbcb11a76')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.0-fbsd.patch"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.7-libs.patch"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.7-polinguas.patch"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.12-revert-forkpty.patch"
+ patch -Np0 -i "${srcdir}/libgksu-2.0.12-fix-make-3.82.patch"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.12-notests.patch"
+ patch -Np1 -i "${srcdir}/libgksu-2.0.12-automake-1.11.2.patch"
+
+ touch NEWS README
+
+ intltoolize --force --copy --automake
+ autoreconf -fi
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static --disable-schemas-install --disable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="${pkgdir}" install
+ rm -f ${pkgdir}/usr/lib/*.a
+ install -m755 -d "${pkgdir}/usr/share/gconf/schemas"
+ gconf-merge-schema "${pkgdir}/usr/share/gconf/schemas/${pkgname}.schemas" --domain libgksu ${pkgdir}/etc/gconf/schemas/*.schemas
+ rm -f ${pkgdir}/etc/gconf/schemas/*.schemas
+}
diff --git a/libgksu-2.0.0-fbsd.patch b/libgksu-2.0.0-fbsd.patch
new file mode 100644
index 000000000000..5c007be5b4b4
--- /dev/null
+++ b/libgksu-2.0.0-fbsd.patch
@@ -0,0 +1,60 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/libgksu.c libgksu-2.0.0/libgksu/libgksu.c
+--- libgksu-2.0.0.orig/libgksu/libgksu.c 2006-09-14 22:35:51.000000000 -0400
++++ libgksu-2.0.0/libgksu/libgksu.c 2006-12-12 11:28:01.000000000 -0500
+@@ -23,7 +23,12 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <fcntl.h>
++#ifdef __FreeBSD__
++#include <libutil.h>
++#include <termios.h>
++#else
+ #include <pty.h>
++#endif
+ #include <pwd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/Makefile.am libgksu-2.0.0/libgksu/Makefile.am
+--- libgksu-2.0.0.orig/libgksu/Makefile.am 2006-09-14 22:35:52.000000000 -0400
++++ libgksu-2.0.0/libgksu/Makefile.am 2006-12-12 11:28:01.000000000 -0500
+@@ -30,6 +30,6 @@ gksu_run_helper_SOURCES = gksu-run-helpe
+ noinst_PROGRAMS = test-gksu
+ test_gksu_SOURCES = test-gksu.c
+ test_gksu_LDADD = libgksu2.la
+-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0`
++test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
+
+ EXTRA_DIST = libgksu.ver
+diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksu/Makefile.in libgksu-2.0.0/libgksu/Makefile.in
+--- libgksu-2.0.0.orig/libgksu/Makefile.in 2006-09-23 15:37:44.000000000 -0400
++++ libgksu-2.0.0/libgksu/Makefile.in 2006-12-12 11:30:09.000000000 -0500
+@@ -283,7 +283,7 @@ gksu_run_helper_LDFLAGS = `pkg-config --
+ gksu_run_helper_SOURCES = gksu-run-helper.c
+ test_gksu_SOURCES = test-gksu.c
+ test_gksu_LDADD = libgksu2.la
+-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0`
++test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
+ EXTRA_DIST = libgksu.ver
+ all: all-am
+
+diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksuui/Makefile.am libgksu-2.0.0/libgksuui/Makefile.am
+--- libgksu-2.0.0.orig/libgksuui/Makefile.am 2006-09-14 22:35:31.000000000 -0400
++++ libgksu-2.0.0/libgksuui/Makefile.am 2006-12-12 11:28:01.000000000 -0500
+@@ -12,4 +12,4 @@ includedir = ${prefix}/include/$(PACKAGE
+ noinst_PROGRAMS = test-gksuui
+ test_gksuui_SOURCES = test-gksuui.c
+ test_gksuui_LDADD = libgksuui1.0.la
+-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0`
++test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
+diff --exclude-from=/home/dang/.diffrc -up -ruN libgksu-2.0.0.orig/libgksuui/Makefile.in libgksu-2.0.0/libgksuui/Makefile.in
+--- libgksu-2.0.0.orig/libgksuui/Makefile.in 2006-09-23 15:37:44.000000000 -0400
++++ libgksu-2.0.0/libgksuui/Makefile.in 2006-12-12 11:30:22.000000000 -0500
+@@ -250,7 +250,7 @@ libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-c
+ noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
+ test_gksuui_SOURCES = test-gksuui.c
+ test_gksuui_LDADD = libgksuui1.0.la
+-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0`
++test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
+ all: all-am
+
+ .SUFFIXES:
diff --git a/libgksu-2.0.12-automake-1.11.2.patch b/libgksu-2.0.12-automake-1.11.2.patch
new file mode 100644
index 000000000000..0f22166fb8b7
--- /dev/null
+++ b/libgksu-2.0.12-automake-1.11.2.patch
@@ -0,0 +1,25 @@
+Due to the following change, pkglib_PROGRAMS is invalid:
+ http://git.savannah.gnu.org/cgit/automake.git/commit/?id=9ca632642b006ac6b0fc4ce0ae5b34023faa8cbf
+
+https://savannah.nongnu.org/bugs/index.php?35241
+https://bugs.gentoo.org/show_bug.cgi?id=397411
+
+---
+ libgksu/Makefile.am | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libgksu/Makefile.am b/libgksu/Makefile.am
+index 49362f9..3cb1090 100644
+--- a/libgksu/Makefile.am
++++ b/libgksu/Makefile.am
+@@ -22,8 +22,8 @@ includedir = ${prefix}/include/${PACKAGE}
+ pkgconfigdir = ${libdir}/pkgconfig
+ pkgconfig_DATA = libgksu2.pc
+
+-pkglibdir = ${libdir}/${PACKAGE}
+-pkglib_PROGRAMS = gksu-run-helper
++gksulibdir = ${libdir}/${PACKAGE}
++gksulib_PROGRAMS = gksu-run-helper
+ gksu_run_helper_LDADD = ${GLIB_LIBS}
+ gksu_run_helper_SOURCES = gksu-run-helper.c
+
diff --git a/libgksu-2.0.12-fix-make-3.82.patch b/libgksu-2.0.12-fix-make-3.82.patch
new file mode 100644
index 000000000000..0a7c5f142893
--- /dev/null
+++ b/libgksu-2.0.12-fix-make-3.82.patch
@@ -0,0 +1,19 @@
+--- Makefile.am-orig 2010-08-22 16:11:19.872577459 -0500
++++ Makefile.am 2010-08-22 16:11:55.289599110 -0500
+@@ -17,11 +17,11 @@
+
+ if GCONF_SCHEMAS_INSTALL
+ install-data-local:
+- if test -z "$(DESTDIR)" ; then \
+- for p in $(schemas_DATA) ; do \
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+- done \
+- fi
++ if test -z "$(DESTDIR)" ; then \
++ for p in $(schemas_DATA) ; do \
++ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
++ done \
++ fi
+ else
+ install-data-local:
+ endif
diff --git a/libgksu-2.0.12-notests.patch b/libgksu-2.0.12-notests.patch
new file mode 100644
index 000000000000..3787ef6bfc13
--- /dev/null
+++ b/libgksu-2.0.12-notests.patch
@@ -0,0 +1,26 @@
+Index: libgksu-2.0.12/libgksu/Makefile.am
+===================================================================
+--- libgksu-2.0.12.orig/libgksu/Makefile.am
++++ libgksu-2.0.12/libgksu/Makefile.am
+@@ -27,7 +27,7 @@ pkglib_PROGRAMS = gksu-run-helper
+ gksu_run_helper_LDFLAGS = `pkg-config --libs glib-2.0`
+ gksu_run_helper_SOURCES = gksu-run-helper.c
+
+-noinst_PROGRAMS = test-gksu
++EXTRA_PROGRAMS = test-gksu
+ test_gksu_SOURCES = test-gksu.c
+ test_gksu_LDADD = libgksu2.la
+ test_gksu_LDFLAGS = `pkg-config --libs glib-2.0`
+Index: libgksu-2.0.12/libgksuui/Makefile.am
+===================================================================
+--- libgksu-2.0.12.orig/libgksuui/Makefile.am
++++ libgksu-2.0.12/libgksuui/Makefile.am
+@@ -9,7 +9,7 @@ libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-c
+ noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
+ includedir = ${prefix}/include/$(PACKAGE)
+
+-noinst_PROGRAMS = test-gksuui
++EXTRA_PROGRAMS = test-gksuui
+ test_gksuui_SOURCES = test-gksuui.c
+ test_gksuui_LDADD = libgksuui1.0.la
+ test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0`
diff --git a/libgksu-2.0.12-revert-forkpty.patch b/libgksu-2.0.12-revert-forkpty.patch
new file mode 100644
index 000000000000..2c3a8cc786bb
--- /dev/null
+++ b/libgksu-2.0.12-revert-forkpty.patch
@@ -0,0 +1,359 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN libgksu-2.0.12.orig/libgksu/libgksu.c libgksu-2.0.12/libgksu/libgksu.c
+--- libgksu-2.0.12.orig/libgksu/libgksu.c 2009-06-29 13:48:24.000000000 -0400
++++ libgksu-2.0.12/libgksu/libgksu.c 2010-01-12 07:32:10.450657456 -0500
+@@ -1,7 +1,6 @@
+ /*
+ * Gksu -- a library providing access to su functionality
+ * Copyright (C) 2004-2009 Gustavo Noronha Silva
+- * Portions Copyright (C) 2009 VMware, Inc.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+@@ -56,9 +55,6 @@
+ static void
+ gksu_context_launch_complete (GksuContext *context);
+
+-static void
+-read_line (int fd, gchar *buffer, int n);
+-
+ GType
+ gksu_error_get_type (void)
+ {
+@@ -2009,8 +2005,6 @@ gksu_su_fuller (GksuContext *context,
+ for (i = 0 ; cmd[i] != NULL ; i++)
+ g_free (cmd[i]);
+ g_free(cmd);
+-
+- _exit(1);
+ }
+ else if (pid == -1)
+ {
+@@ -2125,10 +2119,10 @@ gksu_su_fuller (GksuContext *context,
+ /* drop the \n echoed on password entry if su did request
+ a password */
+ if (password_needed)
+- read_line (fdpty, buf, 255);
++ read (fdpty, buf, 255);
+ if (context->debug)
+ fprintf (stderr, "DEBUG (run:post-after-pass) buf: -%s-\n", buf);
+- read_line (fdpty, buf, 255);
++ read (fdpty, buf, 255);
+ if (context->debug)
+ fprintf (stderr, "DEBUG (run:post-after-pass) buf: -%s-\n", buf);
+ }
+@@ -2142,9 +2136,7 @@ gksu_su_fuller (GksuContext *context,
+ {
+ int retval = 0;
+
+- /* Red Hat's su shows the full path to su in its error messages. */
+- if (!strncmp (buf, "su:", 3) ||
+- !strncmp (buf, "/bin/su:", 7))
++ if (!strncmp (buf, "su", 2))
+ {
+ gchar **strings;
+
+@@ -2155,11 +2147,7 @@ gksu_su_fuller (GksuContext *context,
+ }
+
+ strings = g_strsplit (buf, ":", 2);
+-
+- /* Red Hat and Fedora use 'incorrect password'. */
+- if (strings[1] &&
+- (g_str_has_prefix(strings[1], " Authentication failure") ||
+- g_str_has_prefix(strings[1], " incorrect password")))
++ if (strings[1] && !strncmp (strings[1], " Authentication failure", 23))
+ {
+ if (used_gnome_keyring)
+ g_set_error (error, gksu_quark,
+@@ -2473,12 +2461,6 @@ gksu_sudo_fuller (GksuContext *context,
+ {
+ char **cmd;
+ char buffer[256] = {0};
+- char *child_stderr = NULL;
+- /* This command is used to gain a token */
+- char *const verifycmd[] =
+- {
+- "/usr/bin/sudo", "-p", "GNOME_SUDO_PASS", "-v", NULL
+- };
+ int argcount = 8;
+ int i, j;
+
+@@ -2489,8 +2471,9 @@ gksu_sudo_fuller (GksuContext *context,
+
+ pid_t pid;
+ int status;
+- FILE *fdfile = NULL;
+- int fdpty = -1;
++ FILE *infile, *outfile;
++ int parent_pipe[2]; /* For talking to the parent */
++ int child_pipe[2]; /* For talking to the child */
+
+ context->sudo_mode = TRUE;
+
+@@ -2565,10 +2548,6 @@ gksu_sudo_fuller (GksuContext *context,
+ cmd[argcount] = g_strdup("-S");
+ argcount++;
+
+- /* Make sudo noninteractive (we should already have a token) */
+- cmd[argcount] = g_strdup("-n");
+- argcount++;
+-
+ /* Make sudo use next arg as prompt */
+ cmd[argcount] = g_strdup("-p");
+ argcount++;
+@@ -2647,21 +2626,26 @@ gksu_sudo_fuller (GksuContext *context,
+ fprintf (stderr, "cmd[%d]: %s\n", i, cmd[i]);
+ }
+
+- pid = forkpty(&fdpty, NULL, NULL, NULL);
+- if (pid == 0)
++ if ((pipe(parent_pipe)) == -1)
+ {
+- // Child
+- setsid(); // make us session leader
+-
+- execv(verifycmd[0], verifycmd);
++ g_set_error (error, gksu_quark, GKSU_ERROR_PIPE,
++ _("Error creating pipe: %s"),
++ strerror(errno));
++ sudo_reset_xauth (context, xauth, xauth_env);
++ return FALSE;
++ }
+
+- g_set_error (error, gksu_quark, GKSU_ERROR_EXEC,
+- _("Failed to exec new process: %s"),
++ if ((pipe(child_pipe)) == -1)
++ {
++ g_set_error (error, gksu_quark, GKSU_ERROR_PIPE,
++ _("Error creating pipe: %s"),
+ strerror(errno));
+ sudo_reset_xauth (context, xauth, xauth_env);
+ return FALSE;
+ }
+- else if (pid == -1)
++
++ pid = fork();
++ if (pid == -1)
+ {
+ g_set_error (error, gksu_quark, GKSU_ERROR_FORK,
+ _("Failed to fork new process: %s"),
+@@ -2669,26 +2653,56 @@ gksu_sudo_fuller (GksuContext *context,
+ sudo_reset_xauth (context, xauth, xauth_env);
+ return FALSE;
+ }
++ else if (pid == 0)
++ {
++ // Child
++ setsid(); // make us session leader
++ close(child_pipe[1]);
++ dup2(child_pipe[0], STDIN_FILENO);
++ dup2(parent_pipe[1], STDERR_FILENO);
+
++ execv(cmd[0], cmd);
++
++ g_set_error (error, gksu_quark, GKSU_ERROR_EXEC,
++ _("Failed to exec new process: %s"),
++ strerror(errno));
++ sudo_reset_xauth (context, xauth, xauth_env);
++ return FALSE;
++ }
+ else
+ {
+ gint counter = 0;
+ gchar *cmdline = NULL;
+- struct termios tio;
+
+ // Parent
+- fdfile = fdopen(fdpty, "w+");
++ close(parent_pipe[1]);
+
+- /* make sure we notice that ECHO is turned off, if it gets
+- turned off */
+- tcgetattr (fdpty, &tio);
+- for (counter = 0; (tio.c_lflag & ECHO) && counter < 15; counter++)
+- {
+- usleep (1000);
+- tcgetattr (fdpty, &tio);
+- }
++ infile = fdopen(parent_pipe[0], "r");
++ if (!infile)
++ {
++ g_set_error (error, gksu_quark, GKSU_ERROR_PIPE,
++ _("Error opening pipe: %s"),
++ strerror(errno));
++ sudo_reset_xauth (context, xauth, xauth_env);
++ return FALSE;
++ }
+
+- fcntl (fdpty, F_SETFL, O_NONBLOCK);
++ outfile = fdopen(child_pipe[1], "w");
++ if (!outfile)
++ {
++ g_set_error (error, gksu_quark, GKSU_ERROR_PIPE,
++ _("Error opening pipe: %s"),
++ strerror(errno));
++ sudo_reset_xauth (context, xauth, xauth_env);
++ return FALSE;
++ }
++
++ /*
++ we are expecting to receive a GNOME_SUDO_PASS
++ if we don't there are two possibilities: an error
++ or a password is not needed
++ */
++ fcntl (parent_pipe[0], F_SETFL, O_NONBLOCK);
+
+ { /* no matter if we can read, since we're using
+ O_NONBLOCK; this is just to avoid the prompt
+@@ -2697,11 +2711,11 @@ gksu_sudo_fuller (GksuContext *context,
+ struct timeval tv;
+
+ FD_ZERO(&rfds);
+- FD_SET(fdpty, &rfds);
++ FD_SET(parent_pipe[0], &rfds);
+ tv.tv_sec = 1;
+ tv.tv_usec = 0;
+
+- select (fdpty + 1, &rfds, NULL, NULL, &tv);
++ select (parent_pipe[0] + 1, &rfds, NULL, NULL, &tv);
+ }
+
+ /* Try hard to find the prompt; it may happen that we're
+@@ -2713,7 +2727,7 @@ gksu_sudo_fuller (GksuContext *context,
+ if (strncmp (buffer, "GNOME_SUDO_PASS", 15) == 0)
+ break;
+
+- read_line (fdpty, buffer, 256);
++ read_line (parent_pipe[0], buffer, 256);
+
+ if (context->debug)
+ fprintf (stderr, "buffer: -%s-\n", buffer);
+@@ -2747,17 +2761,18 @@ gksu_sudo_fuller (GksuContext *context,
+
+ usleep (1000);
+
+- write (fdpty, password, strlen(password) + 1);
+- write (fdpty, "\n", 1);
++ fprintf (outfile, "%s\n", password);
++ fclose (outfile);
+
+ nullify_password (password);
+
+- fcntl(fdpty, F_SETFL, fcntl(fdpty, F_GETFL) & ~O_NONBLOCK);
++ /* turn NONBLOCK off */
++ fcntl(parent_pipe[0], F_SETFL, fcntl(parent_pipe[0], F_GETFL) & ~O_NONBLOCK);
+ /* ignore the first newline that comes right after sudo receives
+ the password */
+- fgets (buffer, 255, fdfile);
+- /* this is the status we are interested in */
+- fgets (buffer, 255, fdfile);
++ fgets (buffer, 255, infile);
++ /* this is the status we are interessted in */
++ fgets (buffer, 255, infile);
+ }
+ else
+ {
+@@ -2766,7 +2781,7 @@ gksu_sudo_fuller (GksuContext *context,
+ fprintf (stderr, "No password prompt found; we'll assume we don't need a password.\n");
+
+ /* turn NONBLOCK off, also if have no prompt */
+- fcntl(fdpty, F_SETFL, fcntl(fdpty, F_GETFL) & ~O_NONBLOCK);
++ fcntl(parent_pipe[0], F_SETFL, fcntl(parent_pipe[0], F_GETFL) & ~O_NONBLOCK);
+
+ should_display = gconf_client_get_bool (context->gconf_client,
+ BASE_PATH "display-no-pass-info", NULL);
+@@ -2785,9 +2800,14 @@ gksu_sudo_fuller (GksuContext *context,
+ fprintf (stderr, "%s", buffer);
+ }
+
+- if (g_str_has_prefix (buffer, "Sorry, try again."))
++ if (!strcmp (buffer, "Sorry, try again.\n"))
+ g_set_error (error, gksu_quark, GKSU_ERROR_WRONGPASS,
+ _("Wrong password."));
++ else if (!strncmp (buffer, "Sorry, user ", 12))
++ g_set_error (error, gksu_quark, GKSU_ERROR_NOT_ALLOWED,
++ _("The underlying authorization mechanism (sudo) "
++ "does not allow you to run this program. Contact "
++ "the system administrator."));
+ else
+ {
+ gchar *haystack = buffer;
+@@ -2805,10 +2825,6 @@ gksu_sudo_fuller (GksuContext *context,
+ }
+ }
+
+- /* If we have an error, let's just stop sudo right there. */
+- if (error)
+- close(fdpty);
+-
+ cmdline = g_strdup("sudo");
+ /* wait for the child process to end or become something other
+ than sudo */
+@@ -2825,23 +2841,17 @@ gksu_sudo_fuller (GksuContext *context,
+ if (context->sn_context)
+ gksu_context_launch_complete (context);
+
++ while (read (parent_pipe[0], buffer, 255) > 0)
++ {
++ fprintf (stderr, "%s", buffer);
++ bzero(buffer, 256);
++ }
++
+ /* if the process is still active waitpid() on it */
+ if (pid_exited != pid)
+ waitpid(pid, &status, 0);
+ sudo_reset_xauth (context, xauth, xauth_env);
+
+- /*
+- * Did token acquisition succeed? If so, spawn sudo in
+- * non-interactive mode. It should either succeed or die
+- * immediately if you're not allowed to run the command.
+- */
+- if (WEXITSTATUS(status) == 0)
+- {
+- g_spawn_sync(NULL, cmd, NULL, 0, NULL, NULL,
+- NULL, &child_stderr, &status,
+- error);
+- }
+-
+ if (exit_status)
+ {
+ if (WIFEXITED(status)) {
+@@ -2853,13 +2863,6 @@ gksu_sudo_fuller (GksuContext *context,
+
+ if (WEXITSTATUS(status))
+ {
+- if (g_str_has_prefix(child_stderr, "Sorry, user "))
+- {
+- g_set_error (error, gksu_quark, GKSU_ERROR_NOT_ALLOWED,
+- _("The underlying authorization mechanism (sudo) "
+- "does not allow you to run this program. Contact "
+- "the system administrator."));
+- }
+ if(cmdline)
+ {
+ /* sudo already exec()ed something else, don't report
+@@ -2868,7 +2871,6 @@ gksu_sudo_fuller (GksuContext *context,
+ if (!g_str_has_suffix (cmdline, "sudo"))
+ {
+ g_free (cmdline);
+- g_free (child_stderr);
+ return FALSE;
+ }
+ g_free (cmdline);
+@@ -2881,11 +2883,11 @@ gksu_sudo_fuller (GksuContext *context,
+ }
+ }
+
+- fprintf(stderr, child_stderr);
+- g_free(child_stderr);
+-
+ /* if error is set we have found an error condition */
+- return (error == NULL);
++ if (error)
++ return FALSE;
++
++ return TRUE;
+ }
+
+ /**
diff --git a/libgksu-2.0.7-libs.patch b/libgksu-2.0.7-libs.patch
new file mode 100644
index 000000000000..b9fb77f27147
--- /dev/null
+++ b/libgksu-2.0.7-libs.patch
@@ -0,0 +1,76 @@
+# https://savannah.nongnu.org/bugs/?25362
+# https://bugs.gentoo.org/show_bug.cgi?id=226837
+diff -Nura a/configure.ac b/configure.ac
+--- a/configure.ac 2009-01-19 22:15:30.000000000 +0100
++++ b/configure.ac 2009-01-19 22:18:10.000000000 +0100
+@@ -43,6 +43,9 @@
+ PKG_CHECK_MODULES(LIBGKSU, [gtk+-2.0 >= 2.4.0, gconf-2.0, libstartup-notification-1.0, gnome-keyring-1, libgtop-2.0])
+ PKG_CHECK_MODULES(GKSU_PROPERTIES, [gtk+-2.0 >= 2.4.0, gconf-2.0, libglade-2.0])
+
++PKG_CHECK_MODULES(GLIB, [glib-2.0 gthread-2.0])
++PKG_CHECK_MODULES(GTK, [gtk+-2.0 gconf-2.0])
++
+ # Checks for library functions.
+ ALL_LINGUAS="ca cs da de es eu fr hu it ko lt pl pt_BR ro ru sk sv nb nl zh_CN"
+
+diff -Nura a/gksu-properties/Makefile.am b/gksu-properties/Makefile.am
+--- a/gksu-properties/Makefile.am 2009-01-19 22:15:59.000000000 +0100
++++ b/gksu-properties/Makefile.am 2009-01-19 22:19:13.000000000 +0100
+@@ -3,7 +3,7 @@
+ AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" -DDATA_DIR=\"$(datadir)\" -DPREFIX=\"$(prefix)\"
+
+ bin_PROGRAMS = gksu-properties
+-gksu_properties_LDFLAGS = ${GKSU_PROPERTIES_LIBS}
++gksu_properties_LDADD = ${GKSU_PROPERTIES_LIBS}
+ gksu_properties_SOURCES = gksu-properties.c
+
+ gladedir = ${prefix}/share/${PACKAGE}
+diff -Nura a/libgksu/Makefile.am b/libgksu/Makefile.am
+--- a/libgksu/Makefile.am 2009-01-19 22:15:59.000000000 +0100
++++ b/libgksu/Makefile.am 2009-01-19 22:18:25.000000000 +0100
+@@ -8,8 +8,8 @@
+ # major -> breaks backward compatibility (changes to existing ABI)
+ # minor -> keeps compatibility (additions to the API)
+ # micro -> no change to the API/ABI
+-libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la
+-libgksu2_la_LDFLAGS = -version-info 0:2:0 -Wl,-O1 -lutil ${LIBGKSU_LIBS}
++libgksu2_la_LIBADD = ../libgksuui/libgksuui1.0.la -lutil ${LIBGKSU_LIBS}
++libgksu2_la_LDFLAGS = -version-info 0:2:0 -Wl,-O1
+ if USE_VERSION_SCRIPT
+ libgksu2_la_LDFLAGS += -Wl,--version-script=libgksu.ver
+ endif
+@@ -24,12 +24,11 @@
+
+ pkglibdir = ${libdir}/${PACKAGE}
+ pkglib_PROGRAMS = gksu-run-helper
+-gksu_run_helper_LDFLAGS = `pkg-config --libs glib-2.0`
++gksu_run_helper_LDADD = ${GLIB_LIBS}
+ gksu_run_helper_SOURCES = gksu-run-helper.c
+
+ noinst_PROGRAMS = test-gksu
+ test_gksu_SOURCES = test-gksu.c
+-test_gksu_LDADD = libgksu2.la
+-test_gksu_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
++test_gksu_LDADD = libgksu2.la ${GLIB_LIBS}
+
+ EXTRA_DIST = libgksu.ver
+diff -Nura a/libgksuui/Makefile.am b/libgksuui/Makefile.am
+--- a/libgksuui/Makefile.am 2009-01-19 22:15:59.000000000 +0100
++++ b/libgksuui/Makefile.am 2009-01-19 22:18:54.000000000 +0100
+@@ -4,12 +4,13 @@
+
+ noinst_LTLIBRARIES = libgksuui1.0.la
+ libgksuui1_0_la_SOURCES = gksuui-dialog.c
+-libgksuui1_0_la_LDFLAGS = -Wl,-O1 `pkg-config --libs gtk+-2.0 gconf-2.0`
++libgksuui1_0_la_LDFLAGS = -Wl,-O1
++libgksuui1_0_la_LIBADD = ${GTK_LIBS}
+
+ noinst_HEADERS = defines.h gksuui.h gksuui-dialog.h
+ includedir = ${prefix}/include/$(PACKAGE)
+
+ noinst_PROGRAMS = test-gksuui
+ test_gksuui_SOURCES = test-gksuui.c
+-test_gksuui_LDADD = libgksuui1.0.la
+-test_gksuui_LDFLAGS = `pkg-config --libs glib-2.0 gthread-2.0`
++test_gksuui_LDADD = libgksuui1.0.la ${GLIB_LIBS}
++
diff --git a/libgksu-2.0.7-polinguas.patch b/libgksu-2.0.7-polinguas.patch
new file mode 100644
index 000000000000..e423af16b44c
--- /dev/null
+++ b/libgksu-2.0.7-polinguas.patch
@@ -0,0 +1,40 @@
+# https://savannah.nongnu.org/bugs/?25360
+diff -Nura a/configure.ac b/configure.ac
+--- a/configure.ac 2009-01-19 21:50:57.000000000 +0100
++++ b/configure.ac 2009-01-19 21:53:21.000000000 +0100
+@@ -50,7 +50,7 @@
+ GETTEXT_PACKAGE=AC_PACKAGE_NAME
+ AC_SUBST(GETTEXT_PACKAGE)
+
+-IT_PROG_INTLTOOL
++IT_PROG_INTLTOOL([0.35.5])
+ AM_GLIB_GNU_GETTEXT
+
+ ##################################################
+diff -Nura a/po/LINGUAS b/po/LINGUAS
+--- a/po/LINGUAS 1970-01-01 01:00:00.000000000 +0100
++++ b/po/LINGUAS 2009-01-19 21:54:24.000000000 +0100
+@@ -0,0 +1,23 @@
++# please keep this list sorted alphabetically
++# http://live.gnome.org/GnomeGoals/PoLinguas
++#
++ca
++cs
++da
++de
++es
++eu
++fr
++hu
++it
++ko
++lt
++pl
++pt_BR
++ro
++ru
++sk
++sv
++nb
++nl
++zh_CN