summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-10-20 00:13:32 +0200
committerTérence Clastres2019-10-20 00:13:32 +0200
commitb96419419245860d401872130147ae85e771723f (patch)
treeff129b9d7c3baf6aabe2e4f3bdc44599bef9f724
parente482de14583ef46d01470a37c1c11eed8908f60f (diff)
downloadaur-libglvnd-glesv2.tar.gz
Sync with ArchLinux
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/libglvnd&id=0e470063a4d5740055cbf28f1d58c105969e269f
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 475f5baff133..518410fa8d41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libglvnd-glesv2
pkgdesc = The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/NVIDIA/libglvnd
arch = x86_64
license = custom:BSD-like
@@ -17,8 +17,10 @@ pkgbase = libglvnd-glesv2
conflicts = libglvnd
source = libglvnd-glesv2-1.2.0.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v1.2.0.tar.gz
source = LICENSE
+ source = 0001-Add-a-configure-option-to-disable-glesv1-or-glesv2.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-Add-a-configure-option-to-disable-glesv1-or-glesv2.patch?h=packages/libglvnd
sha512sums = 0e0e9c3f303739c73f5bee4c2aaef9eff56440345f2f1ce285ee98eb94c1e5e740774dd501aeeed1299aa25a449d813a850e95282999a3ca4648d2381d6c8fa6
sha512sums = bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5
+ sha512sums = b2d2e8fd7ea92bfc913d0b808d15c801e7c3ceb484bdd60700fd1c9ce27b4fbd4b68e568e967599f2e5132cc1ed382ec87a07c16bd3bfa5c4d920f2d9600e689
pkgname = libglvnd-glesv2
depends = libxext
diff --git a/PKGBUILD b/PKGBUILD
index bd0e9263f585..5725c101eb09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libglvnd-glesv2
_pkgname=${pkgname/-glesv2}
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1"
arch=('x86_64')
url="https://github.com/NVIDIA/libglvnd"
@@ -14,16 +14,26 @@ makedepends=('libxext' 'libx11' 'glproto' 'python')
provides=('libglvnd' 'libgl' 'libegl' 'libgles')
conflicts=('libglvnd')
source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$pkgver.tar.gz"
- LICENSE)
+ LICENSE
+ 0001-Add-a-configure-option-to-disable-glesv1-or-glesv2.patch::https://git.archlinux.org/svntogit/packages.git/plain/trunk/0001-Add-a-configure-option-to-disable-glesv1-or-glesv2.patch?h=packages/libglvnd)
sha512sums=('0e0e9c3f303739c73f5bee4c2aaef9eff56440345f2f1ce285ee98eb94c1e5e740774dd501aeeed1299aa25a449d813a850e95282999a3ca4648d2381d6c8fa6'
- 'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
+ 'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5'
+ 'b2d2e8fd7ea92bfc913d0b808d15c801e7c3ceb484bdd60700fd1c9ce27b4fbd4b68e568e967599f2e5132cc1ed382ec87a07c16bd3bfa5c4d920f2d9600e689')
-build() {
+
+prepare() {
cd $_pkgname-$pkgver
+ # merged upstream
+ patch -Np1 -i ../0001-Add-a-configure-option-to-disable-glesv1-or-glesv2.patch
+
./autogen.sh
+}
+
+build() {
+ cd $_pkgname-$pkgver
./configure --prefix=/usr \
- # --disable-headers
+ --disable-gles1
make
}
@@ -35,8 +45,4 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-
- # FS#64044
- rm "$pkgdir"/usr/lib/pkgconfig/glesv1*
- rm "$pkgdir"/usr/lib/libGLESv1*
}