summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Barnett2015-09-05 14:24:15 -0500
committerJames Barnett2015-09-05 14:24:15 -0500
commitd7a111bc2a057771fcc4d81f18c8bc815c33b4ce (patch)
tree2b36a2025249d1077e3018469466b4cd4713f6cf
parent33bcc5076664c515d8661d89f9932a6c0cc95624 (diff)
downloadaur-d7a111bc2a057771fcc4d81f18c8bc815c33b4ce.tar.gz
Release 3.3.1. Add test
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5189dd323de1..5a4a6f0f3d59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libgmxcpp
pkgdesc = A library for use in analyzing GROMACS simulation output files
- pkgver = 3.2
+ pkgver = 3.3.1
pkgrel = 1
url = https://github.com/wesbarnett/libgmxcpp
arch = any
license = GPL,LGPL
makedepends = cmake
- source = https://github.com/wesbarnett/libgmxcpp/archive/v3.2.tar.gz
- md5sums = a482632b75164730debbd5b1799acc22
+ source = https://github.com/wesbarnett/libgmxcpp/archive/v3.3.1.tar.gz
+ md5sums = bfd94ae47211c460abf2d893471531f0
pkgname = libgmxcpp
diff --git a/PKGBUILD b/PKGBUILD
index 9adcfcf984e0..589eb6e8f94a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: James W. Barnett <jbarnet4 at tulane dot edu>
pkgname=libgmxcpp
-pkgver=3.2
+pkgver=3.3.1
pkgrel=1
pkgdesc="A library for use in analyzing GROMACS simulation output files"
arch=(any)
@@ -8,7 +8,7 @@ url="https://github.com/wesbarnett/libgmxcpp"
license=('GPL','LGPL')
makedepends=('cmake')
source=(${url}/archive/v${pkgver}.tar.gz)
-md5sums=('a482632b75164730debbd5b1799acc22')
+md5sums=('bfd94ae47211c460abf2d893471531f0')
build() {
cd "$pkgname-$pkgver"
@@ -17,6 +17,11 @@ build() {
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
}
+check() {
+ cd ${srcdir}/${pkgname}/build
+ make test
+}
+
package() {
cd "$pkgname-$pkgver"/build
make DESTDIR="$pkgdir/" install