summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-11-22 09:47:45 -0500
committerSolomon Choina2019-11-22 09:47:45 -0500
commit79abdd5faa5d217df6912e163d2361a657cdff51 (patch)
tree7562fd459731a0e456f0f8e6ab5be533d4c4c7d9
parent9fcff5d9e51e6debda21020e903ee93d072718e5 (diff)
downloadaur-79abdd5faa5d217df6912e163d2361a657cdff51.tar.gz
python is mandatory via pkg-config
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--libgnt3-python.patch13
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08254a2e672e..4cbeb4a73b04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libgnt3-hg
pkgdesc = The GLib Ncurses Toolkit
- pkgver = r1337.04d9c8e5cb95
+ pkgver = r1371+.88c07b4791fa+
pkgrel = 1
epoch = 1
url = https://bitbucket.org/pidgin/libgnt
@@ -19,7 +19,9 @@ pkgbase = libgnt3-hg
provides = libgnt3-hg
conflicts = libgnt3-hg
source = hg+https://bitbucket.org/pidgin/libgnt#branch=default
+ source = libgnt3-python.patch
sha256sums = SKIP
+ sha256sums = de8cf41d2aaa10afd630a55153f61e87b78d52ced02f4895de2362e9c794a85b
pkgname = libgnt3-hg
diff --git a/PKGBUILD b/PKGBUILD
index 6a065a6d26ec..5a827cd4f39c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=libgnt3-hg
-pkgver=r1337.04d9c8e5cb95
+pkgver=r1371+.88c07b4791fa+
epoch=1
pkgrel=1
pkgdesc="The GLib Ncurses Toolkit"
@@ -11,8 +11,10 @@ depends=('glib2' 'ncurses' 'libxml2' 'python')
makedepends=('mercurial' 'meson' 'libxml2' 'python' 'gobject-introspection' 'gtk-doc')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
-source=('hg+https://bitbucket.org/pidgin/libgnt#branch=default')
-sha256sums=('SKIP')
+source=('hg+https://bitbucket.org/pidgin/libgnt#branch=default'
+ 'libgnt3-python.patch')
+sha256sums=('SKIP'
+ 'de8cf41d2aaa10afd630a55153f61e87b78d52ced02f4895de2362e9c794a85b')
pkgver() {
cd "$srcdir/${pkgname%3-hg}"
@@ -20,6 +22,11 @@ pkgver() {
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
+prepare() {
+ cd "$srcdir/${pkgname%3-hg}"
+ patch -Np1 -i ../libgnt3-python.patch
+}
+
build() {
arch-meson libgnt build
ninja -C build
diff --git a/libgnt3-python.patch b/libgnt3-python.patch
new file mode 100644
index 000000000000..8e9b86e73d72
--- /dev/null
+++ b/libgnt3-python.patch
@@ -0,0 +1,13 @@
+diff --unified --recursive --text libgnt.orig/meson.build libgnt.new/meson.build
+--- libgnt.orig/meson.build 2019-11-22 09:33:50.667726131 -0500
++++ libgnt.new/meson.build 2019-11-22 09:37:48.015959685 -0500
+@@ -204,8 +204,7 @@
+ ]
+
+ # Check for Python headers
+-python_dep = dependency('python3', required : false)
+-gnt_config.set('USE_PYTHON', python_dep.found())
++python_dep = dependency('python3', required : true)
+
+ configure_file(output : 'gntconfig.h',
+ configuration : gnt_config)