summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-05-14 10:01:57 -0400
committerSolomon Choina2020-05-14 10:01:57 -0400
commitb406e7e92d23ea244633b3c4d5e82bdf06f0f3fd (patch)
tree261569e4a8b02d65fb273747914729803c201d7d
parentfd81ba675195eb7c63c8463263f34fa9c45532d8 (diff)
downloadaur-b406e7e92d23ea244633b3c4d5e82bdf06f0f3fd.tar.gz
the python stuff was changed upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--libgnt3-python.patch13
3 files changed, 6 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e05d19cfdfd..0a837bd5870c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libgnt3-hg
pkgdesc = The GLib Ncurses Toolkit
- pkgver = r1371.88c07b4791fa
- pkgrel = 2
+ pkgver = r1374.8672fda6d081
+ pkgrel = 1
epoch = 1
url = https://bitbucket.org/pidgin/libgnt
arch = x86_64
@@ -19,9 +19,7 @@ pkgbase = libgnt3-hg
provides = libgnt3-hg
conflicts = libgnt3-hg
source = hg+https://bitbucket.org/pidgin/libgnt#branch=default
- source = libgnt3-python.patch
sha256sums = SKIP
- sha256sums = dba3a7df0b89b526c3b22df0b483121a6c3f90f396a435b6f6681113d3daf3c3
pkgname = libgnt3-hg
diff --git a/PKGBUILD b/PKGBUILD
index 8e4f31d1ccfd..aa8f53380e55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com>
pkgname=libgnt3-hg
-pkgver=r1371.88c07b4791fa
+pkgver=r1374.8672fda6d081
epoch=1
-pkgrel=2
+pkgrel=1
pkgdesc="The GLib Ncurses Toolkit"
arch=('x86_64')
url="https://bitbucket.org/pidgin/libgnt"
@@ -11,10 +11,8 @@ depends=('glib2' 'ncurses' 'libxml2' 'python')
makedepends=('mercurial' 'meson' 'libxml2' 'python' 'gobject-introspection' 'gtk-doc')
provides=("${pkgname%-VCS}")
conflicts=("${pkgname%-VCS}")
-source=('hg+https://bitbucket.org/pidgin/libgnt#branch=default'
- 'libgnt3-python.patch')
-sha256sums=('SKIP'
- 'dba3a7df0b89b526c3b22df0b483121a6c3f90f396a435b6f6681113d3daf3c3')
+source=('hg+https://bitbucket.org/pidgin/libgnt#branch=default')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%3-hg}"
@@ -22,11 +20,6 @@ pkgver() {
printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
}
-prepare() {
- cd "$srcdir/${pkgname%3-hg}"
- patch -Np1 -i ../libgnt3-python.patch
-}
-
build() {
arch-meson libgnt build
ninja -C build
diff --git a/libgnt3-python.patch b/libgnt3-python.patch
deleted file mode 100644
index 9e87275ed72d..000000000000
--- a/libgnt3-python.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --unified --recursive --text libgnt.orig/meson.build libgnt.new/meson.build
---- libgnt.orig/meson.build 2019-11-22 09:33:50.667726131 -0500
-+++ libgnt.new/meson.build 2019-11-22 09:37:48.015959685 -0500
-@@ -204,8 +204,7 @@
- ]
-
- # Check for Python headers
--python_dep = dependency('python3', required : false)
--gnt_config.set('USE_PYTHON', python_dep.found())
-+python_dep = dependency('python3', required : false)
-
- configure_file(output : 'gntconfig.h',
- configuration : gnt_config)