summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2022-12-19 11:50:19 +0000
committergrufo2022-12-19 11:50:19 +0000
commit778bef3a0cbdb286f9377e66b238b96734e19321 (patch)
tree60eb15eeb7e6c1016d5409b8ea1b2d289602fef7
downloadaur-778bef3a0cbdb286f9377e66b238b96734e19321.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eee17d60b509
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libgnuisance
+ pkgdesc = GTK New User Interfaces
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/madmurphy/libgnuisance
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gtk-doc
+ depends = glib2
+ depends = libadwaita
+ depends = gtk4
+ conflicts = libgnuisance-git
+ conflicts = libgnuisance-bin
+ source = https://github.com/madmurphy/libgnuisance/releases/download/0.1.0/libgnuisance-0.1.0-with-configure.tar.gz
+ sha256sums = 5da249887a143fbda6c5e57d1d264530cdc2a9a64f8ebdd3ac431dc9db18eafb
+
+pkgname = libgnuisance
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8affb002cf2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+pkgname='libgnuisance'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc='GTK New User Interfaces'
+arch=('i686' 'x86_64')
+url='https://github.com/madmurphy/libgnuisance'
+license=('GPL')
+depends=('glib2' 'libadwaita' 'gtk4')
+makedepends=('gtk-doc')
+conflicts=("${pkgname}-git" "${pkgname}-bin")
+source=("https://github.com/madmurphy/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}-with-configure.tar.gz")
+sha256sums=('5da249887a143fbda6c5e57d1d264530cdc2a9a64f8ebdd3ac431dc9db18eafb')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-gtk-doc
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+