summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2022-01-24 16:29:32 +0000
committergrufo2022-01-24 16:29:32 +0000
commitb1ecfdf43eb01aa0b3162a4bef1f1563a8aad3c2 (patch)
tree9b5d42d5f41278473bb3cfc03a173dc81ab48936
downloadaur-b1ecfdf43eb01aa0b3162a4bef1f1563a8aad3c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be9d5e222539
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libgnunetworker-git
+ pkgdesc = Multithreading with GNUnet
+ pkgver = r1.ec1d63f
+ pkgrel = 1
+ url = https://github.com/madmurphy/libgnunetworker
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ depends = gettext
+ depends = gnunet
+ provides = libgnunetworker
+ conflicts = libgnunetworker
+ conflicts = libgnunetworker-bin
+ source = git+https://github.com/madmurphy/libgnunetworker.git
+ md5sums = SKIP
+
+pkgname = libgnunetworker-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1dc239c6fa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+
+_libname='libgnunetworker'
+pkgname="${_libname}-git"
+pkgver='r1.ec1d63f'
+pkgrel=1
+pkgdesc='Multithreading with GNUnet'
+arch=('i686' 'x86_64')
+url="https://github.com/madmurphy/${_libname}"
+license=('AGPL')
+depends=('gettext' 'gnunet')
+provides=("${_libname}")
+conflicts=("${_libname}" "${_libname}-bin")
+source=("git+https://github.com/madmurphy/${_libname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_libname}"
+ printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_libname}"
+ ./bootstrap --noconfigure
+}
+
+build() {
+ cd "${srcdir}/${_libname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${_libname}"
+ make DESTDIR="${pkgdir}" install
+}
+