summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Koloska2015-07-07 23:35:51 +0200
committerUwe Koloska2015-07-07 23:35:51 +0200
commit2e9b7c3c4314c31de6cdda3ea62100a30b6415f1 (patch)
treeb9fb2fe2e2f9a1c400fbca82a4d8e1a153d58adf
downloadaur-2e9b7c3c4314c31de6cdda3ea62100a30b6415f1.tar.gz
Initial import
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3dfe7ece77ac
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = libgnutls26
+ pkgdesc = gnutls26 library (shared objects)
+ pkgver = 2.12.23
+ pkgrel = 18
+ url = http://www.gnutls.org/
+ arch = i686
+ arch = x86_64
+ license = LGPLv3
+ source = http://ftp.debian.org/debian/pool/main/g/gnutls26/libgnutls26_2.12.23-18_i386.deb
+
+pkgname = libgnutls26
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7aeb6c2ceff2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libgnutls26
+ pkgdesc = gnutls26 library (shared objects)
+ pkgver = 2.12.23
+ pkgrel = 18
+ url = http://www.gnutls.org/
+ arch = i686
+ arch = x86_64
+ license = LGPLv3
+ source = http://ftp.debian.org/debian/pool/main/g/gnutls26/libgnutls26_2.12.23-18_i386.deb
+ md5sums = 4f36c0f9ca711af91164db3ecdfdb7b2
+
+pkgname = libgnutls26
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..869b608d98e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Uwe Koloska <kolewu@koloro.de>
+# Contributor: Sairon Istyar <saironiq@gmail.com>
+
+pkgname=libgnutls26
+pkgver=2.12.23
+_sover=26.22.6
+pkgrel=18
+pkgdesc='gnutls26 library (shared objects)'
+arch=('i686' 'x86_64')
+url="http://www.gnutls.org/"
+license=(LGPLv3)
+
+if [ "${CARCH}" = "x86_64" ] ; then
+ _arch="amd64"
+ _arch2="x86_64"
+ source=(http://ftp.debian.org/debian/pool/main/g/gnutls26/${pkgname}_${pkgver}-${pkgrel}_amd64.deb)
+ md5sums=('781c367990e74fb756611748a2ef4a0b')
+else
+ _arch="i386"
+ _arch2="i386"
+ source=(http://ftp.debian.org/debian/pool/main/g/gnutls26/${pkgname}_${pkgver}-${pkgrel}_i386.deb)
+ md5sums=('4f36c0f9ca711af91164db3ecdfdb7b2')
+fi
+
+package() {
+ ar vx $srcdir/libgnutls26_${pkgver}-${pkgrel}_${_arch}.deb
+ tar xvf $srcdir/data.tar.xz
+ install -Dm755 $srcdir/usr/lib/${_arch2}-linux-gnu/libgnutls.so.${_sover} $pkgdir/usr/lib/libgnutls.so.${_sover}
+ ln -s libgnutls.so.${_sover} $pkgdir/usr/lib/libgnutls.so.26
+ install -Dm755 $srcdir/usr/lib/${_arch2}-linux-gnu/libgnutls-extra.so.${_sover} $pkgdir/usr/lib/libgnutls-extra.so.${_sover}
+ ln -s libgnutls-extra.so.${_sover} $pkgdir/usr/lib/libgnutls-extra.so.26
+}