summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-06-08 17:52:49 +0200
committereolianoe2015-06-08 17:52:49 +0200
commitbf66c085f0ecf298f21c1b6b4c5ebb0b3a25a8b7 (patch)
treecda240defcd3abc1fed860bf648e8c6b7ca0ae69
downloadaur-bf66c085f0ecf298f21c1b6b4c5ebb0b3a25a8b7.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e312cc8d156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libgomp-docs
+ pkgdesc = Documentation of libgomp (GNU implementation of the OpenMP)
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = https://gcc.gnu.org/onlinedocs/
+ arch = any
+ license = GPL
+ options = docs
+ options = !strip
+ source = https://gcc.gnu.org/onlinedocs/gcc-5.1.0/libgomp-html.tar.gz
+ sha256sums = 427a954cd51e981fb43880ef6c2d7cfb50a0a8bb44f4453617e31f3995edcfec
+
+pkgname = libgomp-docs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0716616d8775
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: eolianoe <eolianoe At GMAIL DoT com>
+# Based on the gcc-docs PKGBUILD available in community
+_pkgname=libgomp
+pkgname=${_pkgname}-docs
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="Documentation of libgomp (GNU implementation of the OpenMP)"
+arch=('any')
+url="https://gcc.gnu.org/onlinedocs/"
+license=('GPL')
+options=('docs' '!strip')
+source=("https://gcc.gnu.org/onlinedocs/gcc-${pkgver}/${_pkgname}-html.tar.gz")
+sha256sums=('427a954cd51e981fb43880ef6c2d7cfb50a0a8bb44f4453617e31f3995edcfec')
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ cp -- *.html "${pkgdir}/usr/share/doc/${_pkgname}"
+}