summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg Erwin2018-11-30 21:40:47 -0800
committerGreg Erwin2018-11-30 21:40:47 -0800
commit5520ec4af71c05030850eb270825d30260e0a99c (patch)
treef95d8403c173e069743f00709f1285bbbad5d297
parent49936872e9a3ef49a2f5d8a2d349763322004a8f (diff)
downloadaur-5520ec4af71c05030850eb270825d30260e0a99c.tar.gz
Add libgpiod to conflicts array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96dd8304056b..fa787d9a1c8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libgpiod-git
pkgdesc = C library and tools for interacting with the linux GPIO character device
- pkgver = r602.039b301
- pkgrel = 2
+ pkgver = r673.02f935e
+ pkgrel = 1
url = https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
arch = x86_64
arch = i686
@@ -14,6 +14,8 @@ pkgbase = libgpiod-git
makedepends = autoconf-archive
depends = linux>=4.8
depends = python
+ provides = libgpiod
+ conflicts = libgpiod
source = git://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 079ecd302a3e..39dfdd4f6653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Greg Erwin <first name last name 256 at gmail dot com>
pkgname=libgpiod-git
-pkgver=r602.039b301
-pkgrel=2
+pkgver=r673.02f935e
+pkgrel=1
pkgdesc="C library and tools for interacting with the linux GPIO character device"
url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
license=('LGPL2.1')
depends=('linux>=4.8' 'python')
+conflicts=('libgpiod')
+provides=('libgpiod')
makedepends=('git' 'autoconf-archive')
source=('git://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git')
sha1sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
./autogen.sh \
--enable-tools=yes \
--enable-bindings-cxx \
@@ -28,6 +30,6 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
make DESTDIR="$pkgdir/" install
}