summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA.H. Kole2023-04-12 15:56:07 +0200
committerA.H. Kole2023-04-12 15:56:07 +0200
commit695416f6188aa34f3992023282a22bf01fc59a85 (patch)
tree24c26cfbf3e1fcd13bf91ed4f6f14fb21ac547b0
downloadaur-695416f6188aa34f3992023282a22bf01fc59a85.tar.gz
Initialize AUR package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a059af10a51a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libgridxc
+ pkgdesc = A library for the computation of exchange and correlation energies and potentials in radial and 3D grids
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://gitlab.com/siesta-project/libraries/libgridxc
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = BSD3
+ checkdepends = gcc-fortran
+ checkdepends = cmake
+ makedepends = gcc-fortran
+ makedepends = cmake
+ depends = libxc
+ depends = openmpi
+ options = staticlibs
+ source = https://gitlab.com/siesta-project/libraries/libgridxc/uploads/6af4a9d60cb44be98b017cf2913de417/libgridxc-1.1.0.tar.gz
+ sha256sums = d05c8b601619567b34462b5c80c5959faf7feb6e26f4f8a77a083b75919a29b5
+
+pkgname = libgridxc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b3c8b603d30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Arnold Kole <a.h.kole@uu.nl>
+pkgname=libgridxc
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A library for the computation of exchange and correlation energies and potentials in radial and 3D grids"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://gitlab.com/siesta-project/libraries/${pkgname}"
+license=('BSD3')
+depends=('libxc' 'openmpi')
+makedepends=(gcc-fortran cmake)
+checkdepends=(gcc-fortran cmake)
+options=(staticlibs)
+source=(https://gitlab.com/siesta-project/libraries/libgridxc/uploads/6af4a9d60cb44be98b017cf2913de417/$pkgname-$pkgver.tar.gz)
+sha256sums=('d05c8b601619567b34462b5c80c5959faf7feb6e26f4f8a77a083b75919a29b5')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cmake -S. -B_build -DWITH_MPI=ON -DWITH_LIBXC=ON -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_PREFIX_PATH=/usr
+ cmake --build _build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+ cmake --build _build --target test
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ DESTDIR="$pkgdir/" cmake --install _build
+}