summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:03:13 +0200
committerMaxime Gauduin2015-06-09 12:03:13 +0200
commit1011f7d6ab35f54c2c6c0643d4dc12cd9be5f1a4 (patch)
tree327f0aaefd28a1b0515c1c5e2b0e8e67cdf21c43
downloadaur-1011f7d6ab35f54c2c6c0643d4dc12cd9be5f1a4.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf7f39a6ae11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libgsignon-glib
+ pkgdesc = gSSO client library
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = https://01.org/gsso
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ depends = glib2
+ depends = python
+ source = git+https://gitlab.com/accounts-sso/libgsignon-glib.git#commit=799c0b9e
+ sha256sums = SKIP
+
+pkgname = libgsignon-glib
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..dfd7c9e21c63
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=('libgsignon-glib')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc916a179ad5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libgsignon-glib
+pkgver=2.4.0
+pkgrel=1
+pkgdesc='gSSO client library'
+arch=('i686' 'x86_64')
+url='https://01.org/gsso'
+license=('LGPL2.1')
+depends=('glib2' 'python')
+makedepends=('git' 'gobject-introspection' 'gtk-doc')
+source=("git+https://gitlab.com/accounts-sso/libgsignon-glib.git#commit=799c0b9e")
+sha256sums=('SKIP')
+
+build() {
+ cd libgsignon-glib
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --enable-dbus-type='session' \
+ --enable-introspection='yes'
+ make
+}
+
+package() {
+ cd libgsignon-glib
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: