summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-08-28 15:12:35 -0400
committerChris Severance2017-08-28 15:12:35 -0400
commit059fea562c8c41393272c7ffbe364524e7dff2b8 (patch)
treea69dfc22eef61ded87143d06d82831154863ce52
parent7e80e18bf4a5e7d74004c0e9b7fcd183ab097183 (diff)
downloadaur-059fea562c8c41393272c7ffbe364524e7dff2b8.tar.gz
Update to 0.3.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 32 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 781c858ff997..20471dfdcae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
# Generated by mksrcinfo v8
-# Sat Mar 4 19:31:03 UTC 2017
+# Mon Aug 28 19:12:20 UTC 2017
pkgbase = libgxps-git
pkgdesc = An XPS Documents library
- pkgver = 0.2.5.r0.gac54305
+ pkgver = 0.3.0.r0.g762b302
pkgrel = 1
url = https://git.gnome.org/browse/libgxps/
arch = i686
arch = x86_64
license = GPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
makedepends = git
+ makedepends = meson
makedepends = gnome-common
- makedepends = gtk-doc
- makedepends = gobject-introspection
- depends = cairo
+ depends = gtk3
depends = libarchive
+ depends = libjpeg-turbo
depends = libtiff
- provides = libgxps=0.2.5
+ depends = lcms2
+ depends = glib2
+ depends = openssl-1.0
+ provides = libgxps=0.3.0
conflicts = libgxps
source = git://git.gnome.org/libgxps
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index eaf31c3b63fb..7f4eeb66bd8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
+# Contributor: Jan de Groot https://www.archlinux.org/packages/extra/x86_64/libgxps/
# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
set -u
_pkgname='libgxps'
pkgname='libgxps-git'
-pkgver=0.2.5.r0.gac54305
+pkgver=0.3.0.r0.g762b302
pkgrel=1
pkgdesc='An XPS Documents library'
arch=('i686' 'x86_64')
url="https://git.gnome.org/browse/${_pkgname}/"
license=('GPL')
-depends=('cairo' 'libarchive' 'libtiff')
-makedepends=('git' 'gnome-common' 'gtk-doc' 'gobject-introspection')
+depends=('gtk3' 'libarchive' 'libjpeg-turbo' 'libtiff' 'lcms2' 'glib2' 'openssl-1.0')
+makedepends=('gobject-introspection' 'gtk-doc' 'git' 'meson' 'gnome-common')
provides=("${_pkgname}=${pkgver%.r*}")
conflicts=("${_pkgname}")
_verwatch=("${url}" "/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz" 'l')
@@ -20,41 +21,39 @@ sha256sums=('SKIP')
pkgver() {
set -u
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
git describe --tags --long | sed -E -e 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
set +u
}
prepare() {
set -u
- cd "${srcdir}/${_pkgname}"
- ./autogen.sh --prefix='/usr'
- ./configure --prefix='/usr' --disable-test
+ mkdir 'build'
+ cd "${_pkgname}"
set +u
}
build() {
set -u
- cd "${srcdir}/${_pkgname}"
- make -s -j $(nproc)
+ cd 'build'
+ if [ ! -s 'config.h' ]; then
+ meson --prefix='/usr' --buildtype='release' "../${_pkgname}" -Denable-gtk-doc='true' -Denable-man='true'
+ fi
+ ninja
+ set +u
+}
+
+check() {
+ set -u
+ cd 'build'
+ meson test
set +u
}
package() {
set -u
- cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}/" install # This generates some /usr/lib errors
+ cd 'build'
+ DESTDIR="${pkgdir}" ninja install
set +u
- # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
- ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
- ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
- ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
- ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
- ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
- ! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u