summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-05-14 15:52:04 +0200
committerPhilip Goto2020-05-14 15:52:04 +0200
commit293bfee7b530b5b7cf870db1116a0f320a7dc69d (patch)
treedde4cfba3173d9f74edcc20b1b4d4b436c230f86
downloadaur-293bfee7b530b5b7cf870db1116a0f320a7dc69d.tar.gz
Initialize:wq
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f63bb35120d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libhandy-glade-catalog-disabled-git
+ pkgdesc = Library full of GTK+ widgets for mobile phones
+ pkgver = 0.0.13.r267.g8157ecc
+ pkgrel = 1
+ url = https://source.puri.sm/Librem5/libhandy
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = glade
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ provides = libhandy
+ conflicts = libhandy
+ conflicts = libhandy-git
+ source = git+https://source.puri.sm/Librem5/libhandy.git
+ md5sums = SKIP
+
+pkgname = libhandy-glade-catalog-disabled-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b43ef4beab4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=libhandy-glade-catalog-disabled-git
+pkgver=0.0.13.r267.g8157ecc
+pkgrel=1
+pkgdesc="Library full of GTK+ widgets for mobile phones"
+url="https://source.puri.sm/Librem5/libhandy"
+license=(LGPL2.1)
+arch=(i686 x86_64 armv7h aarch64)
+depends=(gtk3)
+makedepends=(git glade gobject-introspection meson vala)
+provides=(libhandy)
+conflicts=(libhandy libhandy-git)
+source=("git+https://source.puri.sm/Librem5/libhandy.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd libhandy
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson libhandy build -Dgtk_doc=true -Dexamples=false -Dglade_catalog=disabled
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}