summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkjwon152018-06-06 05:09:24 +0900
committerkjwon152018-06-06 05:09:24 +0900
commit0e3f5345ced9ec861360d6fd0dc9bcd0f544f5e0 (patch)
tree86850f7d079594533e780d5ae6580705fe005512
downloadaur-0e3f5345ced9ec861360d6fd0dc9bcd0f544f5e0.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD69
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2981030491cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libhangul-3beol
+ pkgdesc = libhangul alternatives
+ pkgver = libhangul.0.1.0.r45.5244cb3
+ pkgrel = 1
+ url = https://github.com/3beol/libhangul
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = intltool
+ makedepends = automake
+ makedepends = autoconf
+ provides = libhangul
+ conflicts = libhangul
+ source = git://github.com/3beol/libhangul
+ md5sums = SKIP
+
+pkgname = libhangul-3beol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b51bd5a24ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Jeong Arm <kjwonmail@gmail.com>
+pkgname=libhangul-3beol
+pkgver=libhangul.0.1.0.r45.5244cb3
+pkgrel=1
+pkgdesc="libhangul alternatives"
+arch=('x86_64')
+url="https://github.com/3beol/libhangul"
+license=('LGPL')
+groups=()
+depends=()
+makedepends=('git' 'intltool' 'automake' 'autoconf')
+provides=('libhangul')
+conflicts=('libhangul')
+replaces=()
+backup=()
+options=()
+install=
+source=('git://github.com/3beol/libhangul')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/libhangul"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/libhangul"
+}
+
+build() {
+ cd "$srcdir/libhangul"
+ touch config.rpath
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/libhangul"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/libhangul"
+ make DESTDIR="$pkgdir/" install
+}