summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmiad2015-06-08 15:44:02 +0300
committerAmiad2015-06-08 15:44:02 +0300
commitb93cd46483c8d36e630a52e17df9adc84f9c885d (patch)
treeb5faee28635462c777c11348e65c0219987f0909
downloadaur-b93cd46483c8d36e630a52e17df9adc84f9c885d.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d985c89901d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libhdate-glib
+ pkgdesc = Gobject bindings for LibHdate. LibHdate is a small C,C++ library for Hebrew calendar, dates, holidays, and reading sequence (parasha).
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = http://libhdate-glib.googlecode.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = autoconf
+ makedepends = automake
+ depends = libhdate>=1.6
+ depends = vala
+ source = http://libhdate-glib.googlecode.com/files/libhdate-glib-0.5.0.tar.bz2
+ md5sums = 072c55c3b5c9f1e8ac202f9fb70b41ac
+
+pkgname = libhdate-glib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d4023c4a136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Amiad Bareli <amiad@hatul.info>
+pkgname=libhdate-glib
+libname=libhdate-glib
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Gobject bindings for LibHdate. LibHdate is a small C,C++ library for Hebrew calendar, dates, holidays, and reading sequence (parasha)."
+url="http://libhdate-glib.googlecode.com"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('libhdate>=1.6' 'vala')
+makedepends=("gcc" "autoconf" "automake")
+source=(http://$libname.googlecode.com/files/$libname-$pkgver.tar.bz2)
+md5sums=('072c55c3b5c9f1e8ac202f9fb70b41ac')
+
+package() {
+ cd $srcdir/$libname-$pkgver
+ sed -i 's/ac_default_prefix=\/usr\/local/ac_default_prefix=\/usr/' ./configure
+ ./configure --prefix=/usr
+ make
+ make DESTDIR=$pkgdir/ install
+}