summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Schoonover2018-11-03 13:16:09 -0700
committerIan Schoonover2018-11-03 13:16:09 -0700
commit2c904b11f91bf6dc83d03e160be697a4bffceef9 (patch)
tree0722c4bf8c4d3f0450cbf024bbe0b82bb2c47ba5
downloadaur-libhunspell1.3.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17dc9e67e485
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libhunspell1.3
+ pkgdesc = Only the libraries provided by hunspell, the spell checker and morphological analyzer
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = http://hunspell.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = MPL
+ depends = gcc-libs
+ depends = readline
+ optdepends = perl: for ispellaff2myspell
+ source = http://downloads.sourceforge.net/hunspell/hunspell-1.3.2.tar.gz
+ md5sums = 3121aaf3e13e5d88dfff13fb4a5f1ab8
+
+pkgname = libhunspell1.3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..32f0ae164510
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df1370936207
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Ian Schoonover <schoonover DOT ian AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
+
+pkgname=libhunspell1.3
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Only the libraries provided by hunspell, the spell checker and morphological analyzer"
+arch=('i686' 'x86_64')
+url="http://hunspell.sourceforge.net/"
+license=('GPL' 'LGPL' 'MPL')
+depends=('gcc-libs' 'readline')
+optdepends=('perl: for ispellaff2myspell')
+source=(http://downloads.sourceforge.net/hunspell/hunspell-$pkgver.tar.gz)
+md5sums=('3121aaf3e13e5d88dfff13fb4a5f1ab8')
+
+build() {
+ cd "$srcdir/hunspell-$pkgver"
+ ./configure --prefix=/usr --disable-static \
+ --with-ui --with-readline --with-experimental
+ make
+}
+
+package() {
+ cd "$srcdir/hunspell-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ # delete everything but libraries
+ rm -rf ${pkgdir}/usr/{bin,include,share}
+ rm -rf ${pkgdir}/usr/lib/pkgconfig
+}
+