summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Borges2019-06-25 21:37:47 +0200
committerMaxime Borges2019-06-25 21:37:47 +0200
commit87d801cc0d2e27bec850edb039cda08a717f8679 (patch)
tree48c8191c8480df0eb370ce570baa66c6b215d1dc
downloadaur-87d801cc0d2e27bec850edb039cda08a717f8679.tar.gz
Init repo based on lib32-icu51
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0740e001a901
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libicu50
+ pkgdesc = International Components for Unicode library, version 50
+ pkgver = 50.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = x86_64
+ license = custom:"icu"
+ depends = gcc-libs>=4.7.1-5
+ source = http://download.icu-project.org/files/icu4c/50.1/icu4c-50_1-src.tgz
+ md5sums = cf7bf9e56aa6c2057a8b6f464046483e
+
+pkgname = libicu50
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d2e7359f42e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Maxime Borges <contact@maximeborg.es>
+
+_setPrefix="/usr"
+_setLibdir="$_setPrefix/lib"
+_pkgbase=icu
+_pkgmaj=50
+_pkgmin=1
+pkgrel=1
+
+pkgname=lib$_pkgbase$_pkgmaj
+pkgver=$_pkgmaj.$_pkgmin
+pkgdesc="International Components for Unicode library, version 50"
+arch=('x86_64')
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs>=4.7.1-5')
+
+source=("http://download.icu-project.org/files/${_pkgbase}4c/${pkgver}/${_pkgbase}4c-${pkgver//./_}-src.tgz")
+
+md5sums=('cf7bf9e56aa6c2057a8b6f464046483e')
+
+build() {
+ export CC='gcc'
+ export CXX='g++'
+ export PKG_CONFIG_PATH='/usr/lib/pkgconfig'
+
+ cd ${srcdir}/icu/source
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --libdir=${_setLibdir}
+ make
+}
+
+package() {
+ cd "${srcdir}/icu/source"
+
+ # Copy only .so libs to the destination dir
+ mkdir -p "${pkgdir}${_setLibdir}"
+ cp -a lib/libicu*50* "${pkgdir}${_setLibdir}"
+
+ # Install the license
+ install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}