summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-03 16:52:38 +0800
committerChocobo12017-08-03 17:28:31 +0800
commit35f85ca5d8271db0f7b5d5376a70a2438c23ce7b (patch)
tree94f2526debb97a1572f6b309ef5f040593386860
downloadaur-35f85ca5d8271db0f7b5d5376a70a2438c23ce7b.tar.gz
newpkg: libidn-git 1.33.r47.g13f07cbf-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc753bd4428d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libidn-git
+ pkgdesc = An implementation of the Stringprep, Punycode and IDNA 2003 specifications
+ pkgver = 1.33.r47.g13f07cbf
+ pkgrel = 1
+ url = https://www.gnu.org/software/libidn/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = gengetopt
+ makedepends = gperf
+ makedepends = gtk-doc
+ depends = glibc
+ provides = libidn
+ conflicts = libidn
+ source = git+https://git.savannah.gnu.org/git/libidn.git
+ sha256sums = SKIP
+
+pkgname = libidn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e803c33987aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libidn-git
+pkgver=1.33.r47.g13f07cbf
+pkgrel=1
+pkgdesc="An implementation of the Stringprep, Punycode and IDNA 2003 specifications"
+arch=('i686' 'x86_64')
+url="https://www.gnu.org/software/libidn/"
+license=('GPL' 'LGPL')
+depends=('glibc')
+makedepends=('git' 'gengetopt' 'gperf' 'gtk-doc')
+provides=('libidn')
+conflicts=('libidn')
+source=("git+https://git.savannah.gnu.org/git/libidn.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libidn"
+
+ git describe --long --tags | sed 's/^libidn.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libidn"
+
+ make bootstrap
+ ./configure --prefix="/usr" --enable-gtk-doc
+ make
+}
+
+check() {
+ cd "libidn"
+
+ make check
+}
+
+package() {
+ cd "libidn"
+
+ make DESTDIR="$pkgdir" install
+}