summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2020-08-06 21:08:43 +0200
committerJiří Klimeš2020-08-06 21:13:17 +0200
commit17734aa15b450c7b783aa8b5d8de690de02686cf (patch)
tree383eaf4fbdeae4af514114e0d4dc70abdd38f2c1
parentea99c414a6cfe630e8af3557f82fddfa4b7313e0 (diff)
downloadaur-17734aa15b450c7b783aa8b5d8de690de02686cf.tar.gz
Do not use msg2 function
It is an internal function of makepkg and should not be used in PKGBUILD. https://bugs.archlinux.org/task/43502 https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_etiquette
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d00c71164e12..bcbca7c5afe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,27 +26,27 @@ prepare() {
build() {
cd "$srcdir"/im/src
- msg2 'Building libim without Lua'
+ echo 'Building libim without Lua'
make -k im im_jp2 im_process im_process_omp im_fftw3
- msg2 'Building Lua 5.4 bindings'
+ echo 'Building Lua 5.4 bindings'
make -k imlua5 imlua_jp25 imlua_process5 imlua_process_omp5 imlua_fftw35 \
STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.4,--enable-new-dtags,--as-needed" \
USE_LUA54=Yes LUA_SFX=5.4
- msg2 'Building Lua 5.3 bindings'
+ echo 'Building Lua 5.3 bindings'
make -k imlua5 imlua_jp25 imlua_process5 imlua_process_omp5 imlua_fftw35 \
STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.3,--enable-new-dtags,--as-needed" \
LUA_INC=/usr/include/lua5.3 \
USE_LUA53=Yes LUA_SFX=5.3
- msg2 'Building Lua 5.2 bindings'
+ echo 'Building Lua 5.2 bindings'
make -k imlua5 imlua_jp25 imlua_process5 imlua_process_omp5 imlua_fftw35 \
STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.2,--enable-new-dtags,--as-needed" \
LUA_INC=/usr/include/lua5.2 \
USE_LUA52=Yes LUA_SFX=5.2
- msg2 'Building Lua 5.1 bindings'
+ echo 'Building Lua 5.1 bindings'
make -k imlua5 imlua_jp25 imlua_process5 imlua_process_omp5 imlua_fftw35 \
STDLDFLAGS="-shared -Wl,-rpath=/usr/lib/lua/5.1,--enable-new-dtags,--as-needed" \
LUA_INC=/usr/include/lua5.1 \