summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMika Attila2015-06-19 13:42:35 +0200
committerMika Attila2015-06-19 13:42:35 +0200
commit54d6e40c53c3f8dcd381cad43b345b49da79567d (patch)
treebe4b432cbc2d045c9c09dd77448ee7fa8c22fe5a
downloadaur-54d6e40c53c3f8dcd381cad43b345b49da79567d.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD44
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49e1a03fe2e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libim
+ pkgdesc = Toolkit for Digital Imaging
+ pkgver = 3.9.1
+ pkgrel = 4
+ url = http://www.tecgraf.puc-rio.br/im/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = zlib
+ optdepends = lua: bindings for Lua are available
+ optdepends = fftw: for fft support
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/imtoolkit/3.9.1/Docs%20and%20Sources/im-3.9.1_Sources.tar.gz
+ source = http://downloads.sourceforge.net/project/imtoolkit/3.9.1/Docs%20and%20Sources/im-3.9.1_Docs.pdf
+ source = LICENSE
+ md5sums = f2626e894acc42a1c67adc318124d890
+ md5sums = 97d806f9493e6c7b7a9f72d15f902d77
+ md5sums = 214b5ab19962418fa755a45b35504219
+
+pkgname = libim
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b3be89a849fc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+****************************************************************************
+Copyright (C) 1994-2010 Tecgraf, PUC-Rio.
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+****************************************************************************
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4174eb49cf95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Original contributor: Karro <karolina.lindqvist@kramnet.se>
+#
+# Maintainer: SneakySnake <radiantstatue@gmail.com>
+# Submit issues/pull requests at https://github.com/crumblingstatue/pkgbuilds
+
+pkgname=libim
+pkgver=3.9.1
+pkgrel=4
+pkgdesc="Toolkit for Digital Imaging"
+arch=(i686 x86_64)
+url="http://www.tecgraf.puc-rio.br/im/"
+depends=(gcc-libs zlib)
+optdepends=('lua: bindings for Lua are available'
+ 'fftw: for fft support')
+license=('custom')
+options=(staticlibs)
+
+source=(
+ "http://downloads.sourceforge.net/project/imtoolkit/${pkgver}/Docs%20and%20Sources/im-${pkgver}_Sources.tar.gz"
+ "http://downloads.sourceforge.net/project/imtoolkit/${pkgver}/Docs%20and%20Sources/im-${pkgver}_Docs.pdf"
+ LICENSE
+)
+
+md5sums=(
+ 'f2626e894acc42a1c67adc318124d890'
+ '97d806f9493e6c7b7a9f72d15f902d77'
+ '214b5ab19962418fa755a45b35504219'
+)
+
+build() {
+ cd $srcdir/im
+ make -C src || return 1
+}
+
+package() {
+ install -m755 -d $pkgdir/usr/lib
+ install -m644 $srcdir/im/lib/Linux*/libim* $pkgdir/usr/lib
+ install -m755 -d $pkgdir/usr/share/$pkgname
+ install -m644 $srcdir/im-${pkgver}_Docs.pdf $pkgdir/usr/share/$pkgname
+ install -m755 -d $pkgdir/usr/include/im
+ install -m644 $srcdir/im/include/* $pkgdir/usr/include/im
+ mkdir -p $pkgdir/usr/share/licenses/libim
+ install -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/libim
+}