summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2017-08-11 11:42:35 +0800
committerFelix Yan2017-08-11 11:42:35 +0800
commit07005af0cbd6b909a40e944812d3da922afc007a (patch)
treefab18c3b43193d8b1f2af4f35ede1dc5903763d3
downloadaur-07005af0cbd6b909a40e944812d3da922afc007a.tar.gz
addpkg: libime-git r79.1ed603c-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8111cd953cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Aug 11 03:42:20 UTC 2017
+pkgbase = libime-git
+ pkgdesc = A library to support generic input method implementation
+ pkgver = r79.1ed603c
+ pkgrel = 1
+ url = https://github.com/fcitx/libime
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = python
+ depends = boost-libs
+ depends = fcitx5-git
+ source = git+https://github.com/fcitx/libime.git
+ sha512sums = SKIP
+
+pkgname = libime-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a83c23bc2d96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 226039 2017-04-27 13:52:30Z felixonmars $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: csslayer <wengxt AT gmail com>
+
+pkgname=libime-git
+pkgver=r79.1ed603c
+pkgrel=1
+pkgdesc="A library to support generic input method implementation"
+arch=('i686' 'x86_64')
+url="https://github.com/fcitx/libime"
+license=('GPL')
+depends=('boost-libs' 'fcitx5-git')
+makedepends=('boost' 'extra-cmake-modules' 'git' 'python')
+source=("git+https://github.com/fcitx/libime.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd libime
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd libime
+ git submodule update --init
+}
+
+build(){
+ cd libime
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd libime
+ make DESTDIR="$pkgdir" install
+}