summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Baberowski2020-09-02 13:25:49 +0200
committerSebastian Baberowski2020-09-02 13:25:49 +0200
commit1e0827e43aa5eee318602616fb4c08c4037d847f (patch)
tree117100596980273d48a3f929890b514bd60c70df
parent6a21ef89cf438f83fb76271c4aad84ee0c2a4cf6 (diff)
downloadaur-1e0827e43aa5eee318602616fb4c08c4037d847f.tar.gz
Updated to 1.8.6. Removed patch as the change is not included in sources
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--gpsd-api-v10-fix.diff16
3 files changed, 9 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e999f202962..87f6e74a0641 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = libindi-gpsd
pkgdesc = 3rd party drivers for INDI: GPSD
- pkgver = 1.8.5
- pkgrel = 4
+ pkgver = 1.8.6
+ pkgrel = 1
url = http://www.indilib.org/index.php?title=Main_Page
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
- depends = libindi=1.8.5
+ depends = libindi=1.8.6
depends = gpsd
- source = https://github.com/indilib/indi-3rdparty/archive/v1.8.5.tar.gz
- source = gpsd-api-v10-fix.diff
- sha256sums = acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8
- sha256sums = 9fbaf514fa4389ab494978d5e2f12783b63179ae4eda88e4865a772cd90a42ec
+ source = https://github.com/indilib/indi-3rdparty/archive/v1.8.6.tar.gz
+ sha256sums = af4fd1ed174328cb8ff9d2e51da6a838b58206b39e3319cdb8d291d427e20cc0
pkgname = libindi-gpsd
diff --git a/PKGBUILD b/PKGBUILD
index d0c31df502e7..85232fb5c5e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Sebastian Baberowski <sebastian@baberowski.com>
pkgname=libindi-gpsd
-pkgver=1.8.5
-pkgrel=4
+pkgver=1.8.6
+pkgrel=1
pkgdesc="3rd party drivers for INDI: GPSD"
url="http://www.indilib.org/index.php?title=Main_Page"
license=(GPL2)
arch=(i686 x86_64)
depends=(libindi=${pkgver} gpsd)
makedepends=(cmake)
-source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz" "gpsd-api-v10-fix.diff")
-sha256sums=("acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8" "9fbaf514fa4389ab494978d5e2f12783b63179ae4eda88e4865a772cd90a42ec")
+source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
+sha256sums=("af4fd1ed174328cb8ff9d2e51da6a838b58206b39e3319cdb8d291d427e20cc0")
prepare() {
mkdir -p build
@@ -18,7 +18,6 @@ prepare() {
#set all to off by default
sed -i -e '/option(WITH_.*On/s/ On/ Off/' CMakeLists.txt
- patch -Np1 < ${srcdir}/gpsd-api-v10-fix.diff
}
build() {
diff --git a/gpsd-api-v10-fix.diff b/gpsd-api-v10-fix.diff
deleted file mode 100644
index d136665d48c6..000000000000
--- a/gpsd-api-v10-fix.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/indi-gpsd/gps_driver.cpp b/indi-gpsd/gps_driver.cpp
-index 833c11bd..126825f2 100644
---- a/indi-gpsd/gps_driver.cpp
-+++ b/indi-gpsd/gps_driver.cpp
-@@ -249,7 +249,11 @@ IPState GPSD::updateGPS()
- return IPS_ALERT;
- }
-
-+#if GPSD_API_MAJOR_VERSION >= 10
-+ if (gpsData->fix.status == STATUS_NO_FIX)
-+#else
- if (gpsData->status == STATUS_NO_FIX)
-+#endif
- {
- // We have no fix and there is no point in further processing.
- IUSaveText(&GPSstatusT[0], "NO FIX");