summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc-Olivier Barre2020-08-20 10:36:54 +0200
committerMarc-Olivier Barre2020-08-20 10:36:54 +0200
commit37b2646090e1b230bfc126ffeb3f4b933a1a86cf (patch)
tree6bda11f0d1ad4c0c162b6483864f91decfe20751
parent689b03114df83bcde8c566973b2a82af71ff79ae (diff)
downloadaur-37b2646090e1b230bfc126ffeb3f4b933a1a86cf.tar.gz
Apply the gpsd patch
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 182dcf2f292f..50c805aa2f23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=libindi-gpsd
pkgver=1.8.5
-pkgrel=1
+pkgrel=2
pkgdesc="3rd party drivers for INDI: GPSD"
url="http://www.indilib.org/index.php?title=Main_Page"
license=(GPL2)
arch=(i686 x86_64)
depends=(libindi=${pkgver})
makedepends=(cmake)
-source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
-sha256sums=('acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8')
+source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz" "gpsd-api-v10-fix.diff")
+sha256sums=("acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8" "9fbaf514fa4389ab494978d5e2f12783b63179ae4eda88e4865a772cd90a42ec")
prepare() {
mkdir -p build
@@ -18,6 +18,7 @@ prepare() {
#set all to off by default
sed -i -e '/option(WITH_.*On/s/ On/ Off/' CMakeLists.txt
+ patch -Np1 < ${srcdir}/gpsd-api-v10-fix.diff
}
build() {