summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Baberowski2020-05-10 15:26:08 +0200
committerSebastian Baberowski2020-05-10 15:26:08 +0200
commit45fb1c78bf054af9fc5114aa8b0a2835240fe9ee (patch)
tree075af9769d50675551c6e17fe1c601c8ebc76560
parent6c5e0c0490d7519168cb69af759236e2f3edafa1 (diff)
downloadaur-45fb1c78bf054af9fc5114aa8b0a2835240fe9ee.tar.gz
Update to libindi 1.8.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 901070527d80..dd42bb991afc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = libindi-gpsd
pkgdesc = 3rd party drivers for INDI: GPSD
- pkgver = 1.8.1
+ pkgver = 1.8.5
pkgrel = 1
url = http://www.indilib.org/index.php?title=Main_Page
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
- depends = libindi
- source = https://github.com/indilib/indi/archive/v1.8.1.tar.gz
- sha256sums = d9250a60ce0f37c800982ef3f3c3a00a77f4eb9f500f1e96edbc1ea7c988d489
+ depends = libindi=1.8.5
+ source = https://github.com/indilib/indi-3rdparty/archive/v1.8.5.tar.gz
+ sha256sums = acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8
pkgname = libindi-gpsd
diff --git a/PKGBUILD b/PKGBUILD
index 64a7baf6b608..182dcf2f292f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Sebastian Baberowski <sebastian@baberowski.com>
pkgname=libindi-gpsd
-pkgver=1.8.1
+pkgver=1.8.5
pkgrel=1
pkgdesc="3rd party drivers for INDI: GPSD"
url="http://www.indilib.org/index.php?title=Main_Page"
license=(GPL2)
arch=(i686 x86_64)
-depends=(libindi)
+depends=(libindi=${pkgver})
makedepends=(cmake)
-source=("https://github.com/indilib/indi/archive/v${pkgver}.tar.gz")
-sha256sums=('d9250a60ce0f37c800982ef3f3c3a00a77f4eb9f500f1e96edbc1ea7c988d489')
+source=("https://github.com/indilib/indi-3rdparty/archive/v${pkgver}.tar.gz")
+sha256sums=('acbddca69c25b2c46ebc0982e8dbbf4912a43f6a4b45d46b007deab8805caed8')
prepare() {
mkdir -p build
- cd indi-${pkgver}/3rdparty
+ cd indi-3rdparty-${pkgver}
#set all to off by default
sed -i -e '/option(WITH_.*On/s/ On/ Off/' CMakeLists.txt
@@ -24,10 +24,8 @@ build() {
cd build
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DUDEVRULES_INSTALL_DIR=/usr/lib/udev/rules.d \
-DWITH_GPSD=On \
- ../indi-${pkgver}/3rdparty
+ ../indi-3rdparty-${pkgver}
make
}